summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo-hmi/html5-background/html5-background_git.bb13
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-background/html5-background_git.bb b/recipes-demo-hmi/html5-background/html5-background_git.bb
new file mode 100644
index 00000000..c0ac220f
--- /dev/null
+++ b/recipes-demo-hmi/html5-background/html5-background_git.bb
@@ -0,0 +1,13 @@
+SUMMARY = "AGL HTML5 Background Application"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://github.com/AGL-web-applications/background.git;protocol=https;branch=master"
+SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
+
+DEPENDS = "nodejs-native"
+
+inherit aglwgt
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 6ec717bd..176bfefd 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -25,6 +25,7 @@ AGL_APPS = " \
html5-mixer \
html5-mediaplayer \
html5-dashboard \
+ html5-background \
"
RDEPENDS_${PN}_append = " \