summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/icu/icu_70.1.bbappend1
-rw-r--r--recipes-support/icu/icu_70.1_agldemo.inc27
-rw-r--r--recipes-wam/cef/cef_git.bb6
3 files changed, 31 insertions, 3 deletions
diff --git a/recipes-support/icu/icu_70.1.bbappend b/recipes-support/icu/icu_70.1.bbappend
new file mode 100644
index 00000000..b30ade49
--- /dev/null
+++ b/recipes-support/icu/icu_70.1.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'icu_70.1_agldemo.inc', '', d)} \ No newline at end of file
diff --git a/recipes-support/icu/icu_70.1_agldemo.inc b/recipes-support/icu/icu_70.1_agldemo.inc
new file mode 100644
index 00000000..957fe083
--- /dev/null
+++ b/recipes-support/icu/icu_70.1_agldemo.inc
@@ -0,0 +1,27 @@
+PACKAGECONFIG:append = " make-icudata"
+
+do_compile:append () {
+ # just adding below does not enforce a full rebuild
+ # thus force rebuild and investigate
+ echo "new"
+}
+
+do_make_icudata:class-native () {
+ ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)}
+ cd ${S}
+ rm -rf data
+ cp -a ${WORKDIR}/data .
+ AR='${BUILD_AR}' \
+ CC='${BUILD_CC}' \
+ CPP='${BUILD_CPP}' \
+ CXX='${BUILD_CXX}' \
+ RANLIB='${BUILD_RANLIB}' \
+ CFLAGS='${BUILD_CFLAGS}' \
+ CPPFLAGS='${BUILD_CPPFLAGS}' \
+ CXXFLAGS='${BUILD_CXXFLAGS}' \
+ LDFLAGS='${BUILD_LDFLAGS}' \
+ ICU_DATA_FILTER_FILE=${WORKDIR}/filter.json \
+ ./runConfigureICU Linux --with-data-packaging=archive
+ oe_runmake
+ install -Dm644 ${S}/data/out/icudt${ICU_MAJOR_VER}l.dat ${S}/data/in/icudt${ICU_MAJOR_VER}l.dat
+}
diff --git a/recipes-wam/cef/cef_git.bb b/recipes-wam/cef/cef_git.bb
index 67ab694d..ee47d2c9 100644
--- a/recipes-wam/cef/cef_git.bb
+++ b/recipes-wam/cef/cef_git.bb
@@ -1,6 +1,6 @@
require gn-utils.inc
-inherit qemu
+inherit qemu python3native
LICENSE = "Apache-2.0 & BSD-3-Clause & LGPL-2.0-only & LGPL-2.1-only"
@@ -88,7 +88,7 @@ OUT_PATH = "${B}/out/Release_GN_${GN_TARGET_ARCH_NAME}"
DIST_PATH = "${OUT_PATH}/dist/cef-minimal_${GN_TARGET_ARCH_NAME}"
CEF_DATA_PATH = "${datadir}/cef"
-DEPENDS:append = " curl clang clang-native gperf-native dbus libcxx libcxx-native libpng libxslt jpeg compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native compiler-rt compiler-rt-native"
+DEPENDS:append = " ca-certificates-native curl clang clang-native gperf-native dbus libcxx libcxx-native libpng libxslt jpeg jpeg-native compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native compiler-rt compiler-rt-native"
do_sync[depends] += "depot-tools-wam-native:do_populate_sysroot"
do_configure[depends] += "depot-tools-wam-native:do_populate_sysroot"
@@ -301,7 +301,7 @@ do_configure () {
export GCLIENT_PY3=1
export PATH="${DEPOT_TOOLS_DIR}:$PATH"
export GN_DEFINES="${GN_DEFINES}"
-
+ export SSL_CERT_DIR="$OECORE_NATIVE_SYSROOT/etc/ssl/certs/"
cd ${S}
python3 ./build/linux/unbundle/replace_gn_files.py --system-libraries ${GN_UNBUNDLE_LIBS}