aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb14
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb2
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb2
3 files changed, 16 insertions, 2 deletions
diff --git a/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb b/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
new file mode 100644
index 00000000..d2481fe8
--- /dev/null
+++ b/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Homescreen binding and client library for application"
+DESCRIPTION = "agl-service-homescreen is the binding library"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen"
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "dbus glib-2.0 af-binder json-c"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "67962d9837ea37b10c2cf906cbde575cce18ab4b"
+S = "${WORKDIR}/git"
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index f9b02e9f..014c1ae2 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -10,7 +10,7 @@ DEPENDS = "\
qtdeclarative \
qtquickcontrols2 \
pulseaudio \
- agl-service-homescreen-2017 \
+ agl-service-homescreen \
agl-service-windowmanager-2017 \
agl-service-weather \
libqtappfw \
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
index 1bb4e2b6..5c84ebe5 100644
--- a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
@@ -23,5 +23,5 @@ do_install_append() {
install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
}
-RDEPENDS_${PN} = "agl-service-homescreen-2017"
+RDEPENDS_${PN} = "agl-service-homescreen"
PROVIDES += "virtual/libhomescreen"