summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend b/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend
new file mode 100644
index 00000000..5a60105b
--- /dev/null
+++ b/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend
@@ -0,0 +1,16 @@
+inherit cmake_qt5
+
+PACKAGECONFIG ??= "qmlplugins"
+
+PACKAGECONFIG[qmlplugins] = "-Dqt_bindings=On,,qtdeclarative"
+
+INSANE_SKIP_${PN} = "dev-deps"
+
+FILES_${PN} += " \
+ ${OE_QMAKE_PATH_QML}/amb/qmldir \
+ ${OE_QMAKE_PATH_QML}/amb/libambqtquick.so \
+"
+
+FILES_${PN}-dbg += " \
+ ${OE_QMAKE_PATH_QML}/amb/.debug/libambqtquick.so \
+"