summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md257
-rw-r--r--classes/.gitkeep0
-rw-r--r--conf/bblayers.conf.sample22
-rw-r--r--conf/layer.conf10
-rw-r--r--conf/local.conf.sample231
-rw-r--r--recipes-automotive/.gitkeep0
-rw-r--r--recipes-connectivity/.gitkeep0
-rw-r--r--recipes-core/.gitkeep0
-rw-r--r--recipes-crosswalk/.gitkeep0
-rw-r--r--recipes-demo-hmi/.gitkeep0
-rw-r--r--recipes-demo-platform/images/agl-demo-platform.bb24
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-agl.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-automotive.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-connectivity.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-graphics.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-multimedia.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-native.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-navi-lbs.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-security.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-speech-services.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw-web.bb16
-rw-r--r--recipes-demo-platform/packagegroups/packagegroup-agl-appfw.bb25
-rw-r--r--recipes-devtools/.gitkeep0
-rw-r--r--recipes-extended/.gitkeep0
-rw-r--r--recipes-graphics/.gitkeep0
-rw-r--r--recipes-multimedia/.gitkeep0
-rw-r--r--recipes-navi-lbs/.gitkeep0
-rw-r--r--recipes-qt/.gitkeep0
-rw-r--r--recipes-support/.gitkeep0
29 files changed, 729 insertions, 0 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 00000000..d78ecab2
--- /dev/null
+++ b/README.md
@@ -0,0 +1,257 @@
+meta-agl-demo, the Yocto layer for DEMO platform of Automotive Grade Linux
+==========================================================================
+
+The yocto layer 'meta-agl-demo' provides a demo platform and applications
+of AGL Distribution.
+
+AGL is creating an automotive specific Linux distribution that unifies
+the software that has been written in a number of places already,
+such as GENIVI and Tizen IVI.
+
+The AGL community appreciates feedback, ideas, suggestion, bugs and
+documentation just as much as code. Please join the irc conversation
+at the #automotive channel on irc.freenode.net and our mailing list.
+
+For infomation for subscribing to the mailing list
+ [automotive-discussions](http://lists.linuxfoundation.org/mailman/listinfo/automotive-discussions)
+For information about AGL Distribution, see the
+ [AGL Distribution](https://wiki.automotivelinux.org/agl-distro)
+For information abount Getting started with AGL
+ [here](https://wiki.automotivelinux.org/start/getting-started)
+For information about contributing to the AGL Distro
+ [here](https://wiki.automotivelinux.org/agl-distro/contributing)
+
+Layer Dependencies
+------------------
+
+URI: git://git.yoctoproject.org/poky
+> branch: dizzy
+> revision: 5f0d25152bac2d3798663a4ebfdd2df24060f153
+
+URI: git://git.openembedded.org/meta-openembedded
+> layer: meta-oe
+> branch: dizzy
+> revision: 853dcfa0d618dc26bd27b3a1b49494b98d6eee97
+
+URI: https://gerrit.automotivelinux.org/gerrit/AGL/meta-agl
+> branch: master
+> revision: 56eb51bfe05a1dd7c3c49cb7465ed83b0a072c78
+> (or later)
+
+## The Renesas R-Car Gen2 (Porter) board depends in addition on: ##
+
+URI: https://gerrit.automotivelinux.org/gerrit/AGL/meta-renesas
+> branch: agl-1.0-bsp-1.8.0
+> revision: 13a2551505942808752a1721c9a27ce7d35cec33
+> (or later)
+
+Packagegroups
+-------------
+
+AGL Demo Platform's package group design:
+
+Top-level packagegroup,
+> packagegroup-agl-appfw (all packages for demo platform)
+
+This package group can contain sub-package groups like these.
+> packagegroup-agl-appfw-graphics (for graphics subsystem)
+> packagegroup-agl-appfw-agl (for AGL App Fw subystem)
+> ...
+
+The "packagegroups-agl-appfw-*" will contain packages for application and
+frameworks.
+> directory: meta-agl-demo/recipes-demo-platform/packagegroups
+> recipes : packagegroup-agl-appfw-[subsystem].bb
+
+Supported Machine
+-----------------
+
+* QEMU (x86-64) - emulated machine: qemux86-64
+* Renesas R-Car Gen2 (R-Car M2) - machine: porter
+
+Supported Target of bitbake
+------------------------
+
+* `agl-demo-platform` The full image of AGL Demo Platform and applications
+
+Supposed Directory Trees of Layers to build
+-------------------------------------------
+
+* For QEMU
+
+ ${TOPDIR}/
+ meta-agl/
+ meta-agl-demo/
+ meta-openembedded/
+ poky/
+
+* For R-Car M2
+
+ ${TOPDIR}/
+ meta-agl/
+ meta-agl-demo/
+ meta-openembedded/
+ meta-renesas/
+ poky/
+
+Build a QEMU image
+------------------
+
+You can build a QEMU image using the following steps:
+
+1. Export TEMPLATECONF to pick up correct configuration for the build
+ $ export TEMPLATECONF=/full/path/to/meta-agl-demo/conf
+
+2. Run the following command:
+ $ source poky/oe-init-build-env
+
+3. Build the full image of AGL Demo Platform and applications
+ $ bitbake agl-demo-platform
+
+4. Run the emulator
+ $ cd $BUILD_DIR/tmp/deploy/images/qemex86-64
+ $ PATH_TO_POKY/poky/scripts/runqemu qemux86-64 bzImage-qemux86-64.bin \
+ agl-demo-platform-qemux86-64.ext3
+
+ For large screen:
+ $ PATH_TO_POKY/poky/scripts/runqemu qemux86-64 bzImage-qemux86-64.bin \
+ agl-demo-platform-qemux86-64.ext3 \
+ bootparams="uvesafb.mode_option=1280x720-32"
+
+5. Some weston samples are available from weston terminal.
+
+Build a R-Car M2 (porter) image
+-------------------------------
+
+### Software setup
+
+NOTE: These instructions are based on GENIVI wiki, [here](http://wiki.projects.genivi.org/index.php/Hardware_Setup_and_Software_Installation/koelsch%26porter). If these didn't work correctly especially around Renesas Binary Packages, please check there and updated instructions.
+
+#### Getting Source Code and Build image
+
+1. Create a directory for working, then go to there.
+ $ mkdir -p $HOME/ANYWHERE_YOU_WANT_TO_WORK_THERE
+ $ cd $HOME/ANYWHERE_YOU_WANT_TO_WORK_THERE
+ $ export AGL_TOP=`pwd`
+
+2. Get the meta data and checkout
+ $ git clone git://git.yoctoproject.org/poky
+ $ cd poky
+ $ git checkout 5f0d25152bac2d3798663a4ebfdd2df24060f153
+ $ cd -
+ $ git clone git://git.openembedded.org/meta-openembedded
+ $ cd meta-openembedded
+ $ git checkout 853dcfa0d618dc26bd27b3a1b49494b98d6eee97
+ $ cd -
+ $ git clone https://gerrit.automotivelinux.org/gerrit/AGL/meta-agl
+ $ cd meta-agl
+ $ git checkout 56eb51bfe05a1dd7c3c49cb7465ed83b0a072c78
+ $ cd -
+ $ git clone https://gerrit.automotivelinux.org/gerrit/AGL/meta-renesas
+ $ cd meta-renesas
+ $ git checkout c28172567a6325f5692e5d33b1ae1c1e64e59ddf
+ $ cd -
+ $ git clone https://gerrit.automotivelinux.org/gerrit/AGL/meta-agl
+
+#### Obtain and Install Renesas Graphics Drivers
+
+1. Download packages from Renesas
+
+ The graphics and multimedia acceleration packages for the R-Car M2 Porter board
+ can be download directory from [here](http://www.renesas.com/secret/r_car_download/rcar_demoboard.jsp).
+
+ There are 2 ZIP files can be downloaded.
+ * Multimedia and Graphics library which require registeration and click through license
+ > r-car_series_evaluation_software_package_for_linux-*.zip
+ * Related Linux drivers
+ > r-car_series_evaluation_software_package_of_linux_drivers-*.zip
+
+2. Unzip the two downloads into a temporary directory.
+ $ cd $AGL_TOP
+ $ mkdir binary-tmp
+ $ cd binary-tmp
+ $ unzip PATH_TO_DOWNLOAD/r-car_series_evaluation_software_package_for_linux-*.zip
+ $ unzip PATH_TO_DOWNLOAD/r-car_series_evaluation_software_package_of_linux_drivers-*.zip
+
+ After this step there should be two files in binary-tmp:
+ * Multimedia and Graphics library
+ > R-Car_Series_Evaluation_Software_Package_for_Linux-*.tar.gz
+ * Related Linux drivers
+ > R-Car_Series_Evaluation_Software_Package_of_Linux_Drivers-*.tar.gz
+
+3. Extract 2 tar archives
+ $ tar xf R-Car_Series_Evaluation_Software_Package_for_Linux-*.tar.gz
+ $ tar xf R-Car_Series_Evaluation_Software_Package_of_Linux_Drivers-*.tar.gz
+
+4. Copy 2 files manually
+ 1. Locate `EVA_r8a7791_linux_sgx_binaries_gles2.tar.bz2` in the Multimedia and Graphics library deliverable and copy it into the BSP layer.
+ $ cd $AGL_TOP
+ $ cp <path_to_file>/EVA_r8a7791_linux_sgx_binaries_gles2.tar.bz2 \
+ meta-renesas/meta-rcar-gen2/recipes-graphics/gles-module/\
+ gles-user-module/r8a7791_linux_sgx_binaries_gles2.tar.bz2
+
+ 2. Locate `SGX_KM_M2.tar.bz2` in the related linux drivers deliverable and copy it into the BSP layer.
+ $ cp <path_to_file>SGX_KM_M2.tar.bz2 \
+ $ meta-renesas/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module
+
+#### Build from the Source code
+
+You can build a R-Car2 M2 (porter) image using the following steps:
+
+1. Export TEMPLATECONF to pick up correct configuration for the build
+ $ export TEMPLATECONF=$AGL_TOP/meta-renesas/meta-rcar-gen2/conf
+
+2. Run the following command:
+ $ cd $AGL_TOP
+ $ source poky/oe-init-build-env
+
+3. Build the full image of AGL Demo Platform and applications
+ $ bitbake agl-demo-platform
+
+### Deployment (SDCARD)
+
+NOTE: These instructions are based on GENIVI wiki, [here](http://wiki.projects.genivi.org/index.php/Hardware_Setup_and_Software_Installation/koelsch%26porter#Deployment_.28SDCARD.29).
+
+#### Instructions on the host
+
+1. Format SD-Card and then, create single EXT3 partition on it.
+
+2. Mount the SD-Card, for example `/media/$SDCARD_LABEL`.
+
+3. Copy AGL root file system onto the SD-Card
+ 1. Go to build directory
+ $ cd $AGL_TOP/build/tmp/deploy/images/porter
+ 2. Extract the root file system into the SD-Card
+ $ sudo tar --extract --numeric-owner --preserve-permissions --preserve-order \
+ --totals --directory=/media/$SDCARD_LABEL --file=agl-demo-platform-porter.tar.bz2
+ 3. Copy kernel and DTB into the `/boot` of the SD-Card
+ $ sudo cp uImage uImage-r8a7791-porter.dtb /media/$SDCARD_LABEL
+
+4. After the copy finished, unmount SD-Card and insert it into the SD-Card slot of the porter board.
+
+#### Instructions on the host
+
+NOTE: There is details about porter board [here](http://elinux.org/R-Car/Boards/Porter).
+
+NOTE: To boot weston on porter board, we need keyboard and mouse. (USB2.0 can be use for this)
+
+##### Change U-Boot parameters to boot from SD card
+
+1. Power up the board and, using your preferred terminal emulator, stop the board's autoboot by hitting any key.
+
+ > Debug serial settings are 38400 8N1. Any standard terminal emulator program can be used.
+
+2. Set the follow environment variables and save them
+ => setenv bootargs_console console=ttySC6,${baudrate}
+ => setenv bootargs_video vmalloc=384M video=HDMI-A-1:1024x768-32@60
+ => setenv bootcmd_sd 'ext4load mmc 0:1 0x40007fc0 boot/uImage;ext4load mmc 0:1 0x40f00000 boot/uImage-r8a7791-porter.dtb'
+ => setenv bootcmd 'setenv bootargs ${bootargs_console} ${bootargs_video} root=/dev/mmcblk0p1 rw rootfstype=ext3;run bootcmd_sd;bootm 0x40007fc0 - 0x40f00000'
+ => saveenv
+
+##### Boot from SD card
+
+1. After board reset, U-Boot is started and after a countdown, ...
+ Linux boot message should be displayed. Please wait a moment.
+2. Then weston is booted automatically, and weston-terminal appears.
+
+3. Have fun! :)
diff --git a/classes/.gitkeep b/classes/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/classes/.gitkeep
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
new file mode 100644
index 00000000..2025ee72
--- /dev/null
+++ b/conf/bblayers.conf.sample
@@ -0,0 +1,22 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "6"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-yocto \
+ ##OEROOT##/meta-yocto-bsp \
+ ##OEROOT##/../meta-agl/meta-ivi-common \
+ ##OEROOT##/../meta-agl/meta-agl \
+ ##OEROOT##/../meta-agl/meta-agl-bsp \
+ ##OEROOT##/../meta-openembedded/meta-oe \
+ ##OEROOT##/../meta-agl-demo \
+ "
+BBLAYERS_NON_REMOVABLE ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-yocto \
+ ##OEROOT##/../meta-agl/meta-agl \
+ "
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 00000000..0047d613
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "agl-demo"
+BBFILE_PATTERN_agl-demo = "^${LAYERDIR}/"
+BBFILE_PRIORITY_agl-demo = "7"
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
new file mode 100644
index 00000000..de0b9903
--- /dev/null
+++ b/conf/local.conf.sample
@@ -0,0 +1,231 @@
+#
+# This file is your local configuration file and is where all local user settings
+# are placed. The comments in this file give some guide to the options a new user
+# to the system might want to change but pretty much any configuration option can
+# be set in this file. More adventurous users can look at local.conf.extended
+# which contains other examples of configuration which can be placed in this file
+# but new users likely won't need any of them initially.
+#
+# Lines starting with the '#' character are commented out and in some cases the
+# default values are provided as comments to show people example syntax. Enabling
+# the option is a question of removing the # character and making any change to the
+# variable as required.
+
+#
+# Machine Selection
+#
+# You need to select a specific machine to target the build with. There are a selection
+# of emulated machines available which can boot and run in the QEMU emulator:
+#
+#MACHINE ?= "qemuarm"
+#MACHINE ?= "qemumips"
+#MACHINE ?= "qemuppc"
+#MACHINE ?= "qemux86"
+#MACHINE ?= "qemux86-64"
+#
+# There are also the following hardware board target machines included for
+# demonstration purposes:
+#
+#MACHINE ?= "beaglebone"
+#MACHINE ?= "genericx86"
+#MACHINE ?= "genericx86-64"
+#MACHINE ?= "mpc8315e-rdb"
+#MACHINE ?= "edgerouter"
+#
+# This sets the default machine to be qemux86 if no other machine is selected:
+MACHINE ??= "qemux86-64"
+
+#
+# Where to place downloads
+#
+# During a first build the system will download many different source code tarballs
+# from various upstream projects. This can take a while, particularly if your network
+# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
+# can preserve this directory to speed up this part of subsequent builds. This directory
+# is safe to share between multiple builds on the same machine too.
+#
+# The default is a downloads directory under TOPDIR which is the build directory.
+#
+#DL_DIR ?= "${TOPDIR}/downloads"
+
+#
+# Where to place shared-state files
+#
+# BitBake has the capability to accelerate builds based on previously built output.
+# This is done using "shared state" files which can be thought of as cache objects
+# and this option determines where those files are placed.
+#
+# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
+# from these files if no changes were made to the configuration. If changes were made
+# to the configuration, only shared state files where the state was still valid would
+# be used (done using checksums).
+#
+# The default is a sstate-cache directory under TOPDIR.
+#
+#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
+
+#
+# Where to place the build output
+#
+# This option specifies where the bulk of the building work should be done and
+# where BitBake should place its temporary files and output. Keep in mind that
+# this includes the extraction and compilation of many applications and the toolchain
+# which can use Gigabytes of hard disk space.
+#
+# The default is a tmp directory under TOPDIR.
+#
+#TMPDIR = "${TOPDIR}/tmp"
+
+#
+# Default policy config
+#
+# The distribution setting controls which policy settings are used as defaults.
+# The default value is fine for general Yocto project use, at least initially.
+# Ultimately when creating custom policy, people will likely end up subclassing
+# these defaults.
+#
+DISTRO ?= "poky"
+# As an example of a subclass there is a "bleeding" edge policy configuration
+# where many versions are set to the absolute latest code from the upstream
+# source control systems. This is just mentioned here as an example, its not
+# useful to most new users.
+# DISTRO ?= "poky-bleeding"
+
+#
+# Package Management configuration
+#
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
+# to generate the root filesystems.
+# Options are:
+# - 'package_deb' for debian style deb files
+# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
+# - 'package_rpm' for rpm style packages
+# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
+# We default to rpm:
+PACKAGE_CLASSES ?= "package_rpm"
+
+#
+# SDK/ADT target architecture
+#
+# This variable specifies the architecture to build SDK/ADT items for and means
+# you can build the SDK packages for architectures other than the machine you are
+# running the build on (i.e. building i686 packages on an x86_64 host).
+# Supported values are i686 and x86_64
+#SDKMACHINE ?= "i686"
+
+#
+# Extra image configuration defaults
+#
+# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
+# images. Some of these options are added to certain image types automatically. The
+# variable can contain the following options:
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
+# (useful if you want to run the package test suites)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "eclipse-debug" - add Eclipse remote debugging support
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image suitable for development
+# e.g. ssh root access has a blank password
+# There are other application targets that can be used here too, see
+# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
+# We default to enabling the debugging tweaks.
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+
+#
+# Additional image features
+#
+# The following is a list of additional classes to use when building images which
+# enable extra features. Some available options which can be included in this variable
+# are:
+# - 'buildstats' collect build statistics
+# - 'image-mklibs' to reduce shared library files size for an image
+# - 'image-prelink' in order to prelink the filesystem image
+# - 'image-swab' to perform host system intrusion detection
+# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
+# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+
+#
+# Runtime testing of images
+#
+# The build system can test booting virtual machine images under qemu (an emulator)
+# after any root filesystems are created and run tests against those images. To
+# enable this uncomment this line. See classes/testimage(-auto).bbclass for
+# further details.
+#TEST_IMAGE = "1"
+#
+# Interactive shell configuration
+#
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
+# multithreaded and needs to be able to handle the case where more than one parallel
+# process may require the user's attention. The default is iterate over the available
+# terminal types to find one that works.
+#
+# Examples of the occasions this may happen are when resolving patches which cannot
+# be applied, to use the devshell or the kernel menuconfig
+#
+# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
+# Note: currently, Konsole support only works for KDE 3.x due to the way
+# newer Konsole versions behave
+#OE_TERMINAL = "auto"
+# By default disable interactive patch resolution (tasks will just fail instead):
+PATCHRESOLVE = "noop"
+
+#
+# Disk Space Monitoring during the build
+#
+# Monitor the disk space during the build. If there is less that 1GB of space or less
+# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# of the build. The reason for this is that running completely out of space can corrupt
+# files and damages the build in ways which may not be easily recoverable.
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K"
+
+#
+# Shared-state files from other locations
+#
+# As mentioned above, shared state files are prebuilt cache data objects which can
+# used to accelerate build time. This variable can be used to configure the system
+# to search other mirror locations for these objects before it builds the data itself.
+#
+# This can be a filesystem directory, or a remote url such as http or ftp. These
+# would contain the sstate-cache results from previous builds (possibly from other
+# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
+# cache locations to check for the shared objects.
+# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
+# at the end as shown in the examples below. This will be substituted with the
+# correct path within the directory structure.
+#SSTATE_MIRRORS ?= "\
+#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
+#file://.* file:///some/local/dir/sstate/PATH"
+
+
+#
+# Qemu configuration
+#
+# By default qemu will build with a builtin VNC server where graphical output can be
+# seen. The two lines below enable the SDL backend too. This assumes there is a
+# libsdl library available on your build system.
+PACKAGECONFIG_append_pn-qemu-native = " sdl"
+PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+ASSUME_PROVIDED += "libsdl-native"
+
+
+# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
+# track the version of this file when it was generated. This can safely be ignored if
+# this doesn't mean anything to you.
+CONF_VERSION = "1"
diff --git a/recipes-automotive/.gitkeep b/recipes-automotive/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-automotive/.gitkeep
diff --git a/recipes-connectivity/.gitkeep b/recipes-connectivity/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-connectivity/.gitkeep
diff --git a/recipes-core/.gitkeep b/recipes-core/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-core/.gitkeep
diff --git a/recipes-crosswalk/.gitkeep b/recipes-crosswalk/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-crosswalk/.gitkeep
diff --git a/recipes-demo-hmi/.gitkeep b/recipes-demo-hmi/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-demo-hmi/.gitkeep
diff --git a/recipes-demo-platform/images/agl-demo-platform.bb b/recipes-demo-platform/images/agl-demo-platform.bb
new file mode 100644
index 00000000..4ca061d0
--- /dev/null
+++ b/recipes-demo-platform/images/agl-demo-platform.bb
@@ -0,0 +1,24 @@
+# Base image
+require recipes-ivi/images/agl-image-ivi.inc
+
+DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
+demos."
+
+IMAGE_FEATURES_append = " \
+ "
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL_append = " \
+ packagegroup-agl-core \
+ packagegroup-agl-ivi \
+ packagegroup-agl-appfw \
+ packagegroup-ivi-common \
+ "
+
+# for Renesas R-Car2 M2 Porter
+IMAGE_INSTALL_append_porter = " \
+ gles-kernel-module \
+ libegl \
+ libgbm-dev \
+ "
+
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-agl.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-agl.bb
new file mode 100644
index 00000000..cc923fd4
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-agl.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+AGL App Fw Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-agl \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-automotive.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-automotive.bb
new file mode 100644
index 00000000..333195b7
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-automotive.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Automotive Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-automotive \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-connectivity.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-connectivity.bb
new file mode 100644
index 00000000..2b0975ab
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-connectivity.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Connectivity Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-connectivity \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-graphics.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-graphics.bb
new file mode 100644
index 00000000..f71b56cb
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-graphics.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Graphics Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-graphics \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-multimedia.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-multimedia.bb
new file mode 100644
index 00000000..7f00c9f2
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-multimedia.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Multimedia Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-multimedia \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-native.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-native.bb
new file mode 100644
index 00000000..750fe678
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-native.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Native App Fw Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-native \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-navi-lbs.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-navi-lbs.bb
new file mode 100644
index 00000000..d3c2b5ea
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-navi-lbs.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Navigation and Location-Based Services Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-navi-lbs \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-security.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-security.bb
new file mode 100644
index 00000000..3806899d
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-security.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Security Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-security \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-speech-services.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-speech-services.bb
new file mode 100644
index 00000000..5f716c21
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-speech-services.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Speech Services Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-speech-services \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-web.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-web.bb
new file mode 100644
index 00000000..6da65657
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw-web.bb
@@ -0,0 +1,16 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Web App Fw Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-web \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/recipes-demo-platform/packagegroups/packagegroup-agl-appfw.bb b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw.bb
new file mode 100644
index 00000000..cb5636bf
--- /dev/null
+++ b/recipes-demo-platform/packagegroups/packagegroup-agl-appfw.bb
@@ -0,0 +1,25 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-appfw-automotive \
+ packagegroup-agl-appfw-connectivity \
+ packagegroup-agl-appfw-graphics \
+ packagegroup-agl-appfw-multimedia \
+ packagegroup-agl-appfw-navi-lbs \
+ packagegroup-agl-appfw-agl \
+ packagegroup-agl-appfw-native \
+ packagegroup-agl-appfw-web \
+ packagegroup-agl-appfw-security \
+ packagegroup-agl-appfw-speech-services \
+ "
diff --git a/recipes-devtools/.gitkeep b/recipes-devtools/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-devtools/.gitkeep
diff --git a/recipes-extended/.gitkeep b/recipes-extended/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-extended/.gitkeep
diff --git a/recipes-graphics/.gitkeep b/recipes-graphics/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-graphics/.gitkeep
diff --git a/recipes-multimedia/.gitkeep b/recipes-multimedia/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-multimedia/.gitkeep
diff --git a/recipes-navi-lbs/.gitkeep b/recipes-navi-lbs/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-navi-lbs/.gitkeep
diff --git a/recipes-qt/.gitkeep b/recipes-qt/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-qt/.gitkeep
diff --git a/recipes-support/.gitkeep b/recipes-support/.gitkeep
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-support/.gitkeep