summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-%.bbappend1
-rw-r--r--recipes-kernel/linux/linux/btusb.cfg35
-rw-r--r--recipes-kernel/linux/linux/can-devices.cfg30
-rw-r--r--recipes-kernel/linux/linux/disable_most.cfg1
-rw-r--r--recipes-kernel/linux/linux/hid.cfg1
-rw-r--r--recipes-kernel/linux/linux/i2c-led.cfg3
-rw-r--r--recipes-kernel/linux/linux/iiodevice.cfg26
-rw-r--r--recipes-kernel/linux/linux/joystick.cfg9
-rw-r--r--recipes-kernel/linux/linux/most_deps.cfg9
-rw-r--r--recipes-kernel/linux/linux/nfc.cfg34
-rw-r--r--recipes-kernel/linux/linux/rtc.cfg7
-rw-r--r--recipes-kernel/linux/linux/rtl_sdr.cfg4
-rw-r--r--recipes-kernel/linux/linux/usb.cfg9
-rw-r--r--recipes-kernel/linux/linux/usbaudio.cfg2
-rw-r--r--recipes-kernel/linux/linux/usbmodem.cfg7
-rw-r--r--recipes-kernel/linux/linux/uvc.cfg4
-rw-r--r--recipes-kernel/linux/linux/wifi.cfg6
-rw-r--r--recipes-kernel/linux/linux_agldemo.inc38
18 files changed, 226 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-%.bbappend b/recipes-kernel/linux/linux-%.bbappend
new file mode 100644
index 00000000..e6b19c21
--- /dev/null
+++ b/recipes-kernel/linux/linux-%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'linux_agldemo.inc', '', d) if bb.data.inherits_class('kernel', d) else ''}
diff --git a/recipes-kernel/linux/linux/btusb.cfg b/recipes-kernel/linux/linux/btusb.cfg
new file mode 100644
index 00000000..0986578e
--- /dev/null
+++ b/recipes-kernel/linux/linux/btusb.cfg
@@ -0,0 +1,35 @@
+CONFIG_BT=m
+CONFIG_BT_BREDR=y
+CONFIG_BT_RFCOMM=m
+CONFIG_BT_RFCOMM_TTY=y
+CONFIG_BT_BNEP=m
+CONFIG_BT_BNEP_MC_FILTER=y
+CONFIG_BT_BNEP_PROTO_FILTER=y
+CONFIG_BT_HIDP=m
+CONFIG_BT_HS=y
+CONFIG_BT_LE=y
+CONFIG_BT_LEDS=y
+# CONFIG_BT_SELFTEST is not set
+CONFIG_BT_DEBUGFS=y
+
+#
+# Bluetooth device drivers
+#
+CONFIG_BT_INTEL=m
+CONFIG_BT_BCM=m
+CONFIG_BT_RTL=m
+CONFIG_BT_HCIBTUSB=m
+CONFIG_BT_HCIBTUSB_BCM=y
+CONFIG_BT_HCIBTUSB_RTL=y
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIUART_H4=y
+CONFIG_BT_HCIUART_BCSP=y
+CONFIG_BT_HCIBCM203X=m
+CONFIG_BT_HCIBFUSB=m
+CONFIG_CRYPTO_ECB=m
+CONFIG_CRYPTO_CMAC=m
+
+#
+# Bluetooth AVRCP support
+#
+CONFIG_INPUT_UINPUT=y
diff --git a/recipes-kernel/linux/linux/can-devices.cfg b/recipes-kernel/linux/linux/can-devices.cfg
new file mode 100644
index 00000000..2b4f317a
--- /dev/null
+++ b/recipes-kernel/linux/linux/can-devices.cfg
@@ -0,0 +1,30 @@
+#
+# CAN Device Drivers
+#
+CONFIG_CAN_SLCAN=m
+CONFIG_CAN_DEV=m
+CONFIG_CAN_CALC_BITTIMING=y
+# CONFIG_CAN_LEDS is not set
+CONFIG_CAN_C_CAN=m
+CONFIG_CAN_C_CAN_PLATFORM=m
+# CONFIG_CAN_SJA1000 is not set
+# CONFIG_CAN_M_CAN is not set
+# CONFIG_CAN_CC770 is not set
+
+#
+# CAN SPI interfaces
+#
+CONFIG_CAN_MCP251X=m
+
+#
+# CAN USB interfaces
+#
+# CONFIG_CAN_EMS_USB is not set
+CONFIG_CAN_ESD_USB2=m
+CONFIG_CAN_GS_USB=m
+CONFIG_CAN_KVASER_USB=m
+CONFIG_CAN_PEAK_USB=m
+CONFIG_CAN_8DEV_USB=m
+CONFIG_CAN_MCBA_USB=m
+# CONFIG_CAN_SOFTING is not set
+# CONFIG_CAN_DEBUG_DEVICES is not set
diff --git a/recipes-kernel/linux/linux/disable_most.cfg b/recipes-kernel/linux/linux/disable_most.cfg
new file mode 100644
index 00000000..db207dfc
--- /dev/null
+++ b/recipes-kernel/linux/linux/disable_most.cfg
@@ -0,0 +1 @@
+# CONFIG_MOST is not set
diff --git a/recipes-kernel/linux/linux/hid.cfg b/recipes-kernel/linux/linux/hid.cfg
new file mode 100644
index 00000000..327c753a
--- /dev/null
+++ b/recipes-kernel/linux/linux/hid.cfg
@@ -0,0 +1 @@
+CONFIG_HID_MULTITOUCH=y
diff --git a/recipes-kernel/linux/linux/i2c-led.cfg b/recipes-kernel/linux/linux/i2c-led.cfg
new file mode 100644
index 00000000..248b5118
--- /dev/null
+++ b/recipes-kernel/linux/linux/i2c-led.cfg
@@ -0,0 +1,3 @@
+# enabling I2C and LED for demonstrator
+CONFIG_I2C_TINY_USB=y
+CONFIG_LEDS_BLINKM=y
diff --git a/recipes-kernel/linux/linux/iiodevice.cfg b/recipes-kernel/linux/linux/iiodevice.cfg
new file mode 100644
index 00000000..c5b8ff35
--- /dev/null
+++ b/recipes-kernel/linux/linux/iiodevice.cfg
@@ -0,0 +1,26 @@
+#
+# Extcon Device Drivers
+#
+CONFIG_IIO=y
+CONFIG_IIO_BUFFER=y
+CONFIG_IIO_BUFFER_CB=y
+CONFIG_IIO_KFIFO_BUF=y
+CONFIG_IIO_CONFIGFS=m
+CONFIG_IIO_TRIGGER=y
+CONFIG_IIO_CONSUMERS_PER_TRIGGER=2
+CONFIG_IIO_SW_DEVICE=m
+CONFIG_IIO_SW_TRIGGER=m
+
+#
+# IIO dummy driver
+#
+CONFIG_IIO_DUMMY_EVGEN=m
+CONFIG_IIO_SIMPLE_DUMMY=m
+CONFIG_IIO_SIMPLE_DUMMY_EVENTS=y
+CONFIG_IIO_SIMPLE_DUMMY_BUFFER=y
+
+#
+# Triggers - standalone
+#
+CONFIG_IIO_HRTIMER_TRIGGER=m
+CONFIG_IIO_TRIGGERED_BUFFER=m
diff --git a/recipes-kernel/linux/linux/joystick.cfg b/recipes-kernel/linux/linux/joystick.cfg
new file mode 100644
index 00000000..2201bcb0
--- /dev/null
+++ b/recipes-kernel/linux/linux/joystick.cfg
@@ -0,0 +1,9 @@
+CONFIG_INPUT_JOYDEV=y
+CONFIG_INPUT_JOYSTICK=y
+CONFIG_JOYSTICK_ADI=y
+CONFIG_GAMEPORT=y
+CONFIG_HID_LOGITECH=y
+CONFIG_LOGIWHEELS_FF=y
+CONFIG_HID_LOGITECH_HIDPP=y
+CONFIG_LOGITECH_FF=y
+CONFIG_LOGIG940_FF=y
diff --git a/recipes-kernel/linux/linux/most_deps.cfg b/recipes-kernel/linux/linux/most_deps.cfg
new file mode 100644
index 00000000..15ddbd21
--- /dev/null
+++ b/recipes-kernel/linux/linux/most_deps.cfg
@@ -0,0 +1,9 @@
+CONFIG_I2C=y
+CONFIG_USB=y
+CONFIG_MEDIA_SUPPORT=m
+CONFIG_MEDIA_CAMERA_SUPPORT=y
+CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
+CONFIG_MEDIA_CONTROLLER=y
+CONFIG_VIDEO_DEV=m
+CONFIG_VIDEO_V4L2_SUBDEV_API=y
+CONFIG_VIDEO_V4L2=m
diff --git a/recipes-kernel/linux/linux/nfc.cfg b/recipes-kernel/linux/linux/nfc.cfg
new file mode 100644
index 00000000..6d863a07
--- /dev/null
+++ b/recipes-kernel/linux/linux/nfc.cfg
@@ -0,0 +1,34 @@
+CONFIG_NFC=m
+CONFIG_NFC_DIGITAL=m
+CONFIG_NFC_NCI=m
+CONFIG_NFC_NCI_SPI=m
+CONFIG_NFC_HCI=m
+CONFIG_NFC_SHDLC=y
+CONFIG_NFC_TRF7970A=m
+CONFIG_NFC_MEI_PHY=m
+CONFIG_NFC_PORT100=m
+CONFIG_NFC_FDP=m
+CONFIG_NFC_FDP_I2C=m
+CONFIG_NFC_PN544=m
+CONFIG_NFC_PN544_I2C=m
+CONFIG_NFC_PN544_MEI=m
+CONFIG_NFC_PN533=m
+CONFIG_NFC_PN533_USB=m
+CONFIG_NFC_PN533_I2C=m
+CONFIG_NFC_MICROREAD=m
+CONFIG_NFC_MICROREAD_I2C=m
+CONFIG_NFC_MICROREAD_MEI=m
+CONFIG_NFC_MRVL=m
+CONFIG_NFC_MRVL_USB=m
+CONFIG_NFC_MRVL_I2C=m
+CONFIG_NFC_MRVL_SPI=m
+CONFIG_NFC_ST21NFCA=m
+CONFIG_NFC_ST21NFCA_I2C=m
+CONFIG_NFC_ST_NCI=m
+CONFIG_NFC_ST_NCI_I2C=m
+CONFIG_NFC_ST_NCI_SPI=m
+CONFIG_NFC_NXP_NCI=m
+CONFIG_NFC_NXP_NCI_I2C=m
+CONFIG_NFC_S3FWRN5=m
+CONFIG_NFC_S3FWRN5_I2C=m
+CONFIG_NFC_ST95HF=m
diff --git a/recipes-kernel/linux/linux/rtc.cfg b/recipes-kernel/linux/linux/rtc.cfg
new file mode 100644
index 00000000..2641958a
--- /dev/null
+++ b/recipes-kernel/linux/linux/rtc.cfg
@@ -0,0 +1,7 @@
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_LIB=y
+CONFIG_RTC_INTF_SYSFS=y
+CONFIG_RTC_INTF_PROC=y
+CONFIG_RTC_INTF_DEV=y
+CONFIG_RTC_DRV_DS1307=m
+CONFIG_RTC_DRV_DS3232=m
diff --git a/recipes-kernel/linux/linux/rtl_sdr.cfg b/recipes-kernel/linux/linux/rtl_sdr.cfg
new file mode 100644
index 00000000..d4574700
--- /dev/null
+++ b/recipes-kernel/linux/linux/rtl_sdr.cfg
@@ -0,0 +1,4 @@
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
+CONFIG_DVB_USB_V2=m
+CONFIG_DVB_USB_RTL28XXU=m
diff --git a/recipes-kernel/linux/linux/usb.cfg b/recipes-kernel/linux/linux/usb.cfg
new file mode 100644
index 00000000..68955086
--- /dev/null
+++ b/recipes-kernel/linux/linux/usb.cfg
@@ -0,0 +1,9 @@
+CONFIG_USB_SERIAL=y
+CONFIG_USB_SERIAL_GENERIC=y
+CONFIG_USB_ACM=m
+CONFIG_CRC_CCITT=y
+CONFIG_USB_SERIAL_CP210X=y
+CONFIG_USB_SERIAL_FTDI_SIO=m
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_PCI=y
diff --git a/recipes-kernel/linux/linux/usbaudio.cfg b/recipes-kernel/linux/linux/usbaudio.cfg
new file mode 100644
index 00000000..5961f43d
--- /dev/null
+++ b/recipes-kernel/linux/linux/usbaudio.cfg
@@ -0,0 +1,2 @@
+CONFIG_SND_USB=y
+CONFIG_SND_USB_AUDIO=y
diff --git a/recipes-kernel/linux/linux/usbmodem.cfg b/recipes-kernel/linux/linux/usbmodem.cfg
new file mode 100644
index 00000000..3ded931e
--- /dev/null
+++ b/recipes-kernel/linux/linux/usbmodem.cfg
@@ -0,0 +1,7 @@
+CONFIG_USB_USBNET=m
+CONFIG_USB_NET_CDC_MBIM=m
+CONFIG_USB_NET_QMI_WWAN=m
+CONFIG_USB_SIERRA_NET=m
+CONFIG_USB_SERIAL_OPTION=m
+CONFIG_USB_SERIAL_SIERRAWIRELESS=m
+CONFIG_USB_SERIAL_QUALCOMM=m
diff --git a/recipes-kernel/linux/linux/uvc.cfg b/recipes-kernel/linux/linux/uvc.cfg
new file mode 100644
index 00000000..7c6556c1
--- /dev/null
+++ b/recipes-kernel/linux/linux/uvc.cfg
@@ -0,0 +1,4 @@
+CONFIG_VIDEOBUF2_VMALLOC=y
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_USB_VIDEO_CLASS=m
+CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
diff --git a/recipes-kernel/linux/linux/wifi.cfg b/recipes-kernel/linux/linux/wifi.cfg
new file mode 100644
index 00000000..00c2e06e
--- /dev/null
+++ b/recipes-kernel/linux/linux/wifi.cfg
@@ -0,0 +1,6 @@
+CONFIG_CFG80211=m
+CONFIG_MAC80211=m
+CONFIG_WLAN_VENDOR_ATH=m
+CONFIG_ATH9K_HTC=m
+CONFIG_STAGING=y
+CONFIG_R8188EU=m
diff --git a/recipes-kernel/linux/linux_agldemo.inc b/recipes-kernel/linux/linux_agldemo.inc
new file mode 100644
index 00000000..84b61df0
--- /dev/null
+++ b/recipes-kernel/linux/linux_agldemo.inc
@@ -0,0 +1,38 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+
+# Enable assorted USB device support for demo systems
+AGL_KCONFIG_FRAGMENTS += " \
+ usb.cfg \
+ uvc.cfg \
+ hid.cfg \
+ joystick.cfg \
+ usbaudio.cfg \
+ usbmodem.cfg \
+ btusb.cfg \
+ i2c-led.cfg \
+"
+
+# Enable CAN device support
+AGL_KCONFIG_FRAGMENTS += "can-devices.cfg"
+
+# Enable NFC support
+AGL_KCONFIG_FRAGMENTS += "nfc.cfg"
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter (rev 1 and 2)
+AGL_KCONFIG_FRAGMENTS += "wifi.cfg"
+
+# Enable support for RTLSDR
+AGL_KCONFIG_FRAGMENTS += "rtl_sdr.cfg"
+
+# iio-dummy-device support for test IIO device
+AGL_KCONFIG_FRAGMENTS += "iiodevice.cfg"
+
+# External rtc support via e.g. http://wiki.seeedstudio.com/Grove-RTC/
+AGL_KCONFIG_FRAGMENTS += "rtc.cfg"
+
+# Make sure in-kernel MOST drivers are disabled to avoid conflicting
+# with our externally built ones
+AGL_KCONFIG_FRAGMENTS += "disable_most.cfg"
+
+# Enable some things on qemuarm64 so MOST drivers will build and load.
+AGL_KCONFIG_FRAGMENTS_append_qemuarm64 = " most_deps.cfg"