summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb2
-rw-r--r--recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch30
-rw-r--r--recipes-qt/qt5/qtlocation_git.bbappend5
-rw-r--r--recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb (renamed from recipes-support/vboxguestdrivers/vboxguestdrivers_6.0.10.bb)18
5 files changed, 14 insertions, 43 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 43a5be765..d62e61b94 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "agl-demo"
BBFILE_PATTERN_agl-demo = "^${LAYERDIR}/"
BBFILE_PRIORITY_agl-demo = "7"
-LAYERSERIES_COMPAT_agl-demo = "thud"
+LAYERSERIES_COMPAT_agl-demo = "zeus"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
index 164684f2e..2bd16d79c 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -50,7 +50,7 @@ SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
# AUDIO-OLD = "audiomanager"
RDEPENDS_${PN} += "\
- udisks \
+ udisks2 \
${SMARTDEVICELINK} \
"
diff --git a/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch b/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch
deleted file mode 100644
index 164c9f0e5..000000000
--- a/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 85df79b094d1097108a28424d6f9b3b76b3aee62 Mon Sep 17 00:00:00 2001
-From: Tasuku Suzuki <tasuku.suzuki@qt.io>
-Date: Thu, 8 Nov 2018 15:26:57 +0900
-Subject: [PATCH] Fix unstable rotation gesture
-
-Order of touch events are not sorted on some platform. When touch point
-1 and
-2 are swapped, map is rotated 180 degrees in a moment
-
-Change-Id: I9c308b805a6ca54519f26a9ff19217de7f947c17
-Reviewed-by: Paolo Angelelli <paolo.angelelli@qt.io>
----
- src/location/declarativemaps/qquickgeomapgesturearea.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/location/declarativemaps/qquickgeomapgesturearea.cpp b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-index c6f4b42..576aeee 100644
---- a/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-+++ b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-@@ -1087,6 +1087,7 @@ void QQuickGeoMapGestureArea::update()
- m_allPoints << m_touchPoints;
- if (m_allPoints.isEmpty() && !m_mousePoint.isNull())
- m_allPoints << *m_mousePoint.data();
-+ std::sort(m_allPoints.begin(), m_allPoints.end(), [](const QTouchEvent::TouchPoint &tp1, const QTouchEvent::TouchPoint &tp2) { return tp1.id() < tp2.id(); });
-
- touchPointStateMachine();
-
---
-2.7.4
-
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend
deleted file mode 100644
index e0f3a6b2e..000000000
--- a/recipes-qt/qt5/qtlocation_git.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI += " \
- file://0001-Fix-unstable-rotation-gesture.patch \
-"
diff --git a/recipes-support/vboxguestdrivers/vboxguestdrivers_6.0.10.bb b/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb
index 4c7ad3679..62c2b509f 100644
--- a/recipes-support/vboxguestdrivers/vboxguestdrivers_6.0.10.bb
+++ b/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb
@@ -13,18 +13,21 @@ VBOX_NAME = "VirtualBox-${PV}"
SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \
file://Makefile.utils \
- "
-SRC_URI[md5sum] = "8428f7e27b244803df180213bc5d4a68"
-SRC_URI[sha256sum] = "5236148a93267478fb6d306f6343aa9587d3f90f437f54c7b3485bd9d538d2f8"
+"
+SRC_URI[md5sum] = "f4f42fd09857556b04b803fb99cc6905"
+SRC_URI[sha256sum] = "4326576e8428ea3626194fc82646347576e94c61f11d412a669fc8a10c2a1e67"
S = "${WORKDIR}/vbox_module"
export BUILD_TARGET_ARCH="${ARCH}"
export BUILD_TARGET_ARCH_x86-64="amd64"
-EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build' all"
+EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build' KBUILD_VERBOSE=1"
-addtask export_sources before do_patch after do_unpack
+# otherwise 5.2.22 builds just vboxguest
+MAKE_TARGETS = "all"
+
+addtask export_sources after do_patch before do_configure
do_export_sources() {
mkdir -p "${S}"
@@ -40,12 +43,15 @@ do_export_sources() {
}
do_configure_prepend() {
+ # vboxguestdrivers/5.2.6-r0/vbox_module/vboxguest/Makefile.include.header:99: *** The variable KERN_DIR must be a kernel build folder and end with /build without a trailing slash, or KERN_VER must be set. Stop.
+ # vboxguestdrivers/5.2.6-r0/vbox_module/vboxguest/Makefile.include.header:108: *** The kernel build folder path must end in <version>/build, or the variable KERN_VER must be set. Stop.
mkdir -p ${WORKDIR}/${KERNEL_VERSION}
ln -snf ${STAGING_KERNEL_DIR} ${WORKDIR}/${KERNEL_VERSION}/build
}
# compile and install mount utility
-do_compile_append() {
+do_compile() {
+ oe_runmake all
oe_runmake 'LD=${CC}' 'LDFLAGS=${LDFLAGS}' -C ${S}/utils
if ! [ -e vboxguest.ko -a -e vboxsf.ko -a -e vboxvideo.ko ] ; then
echo "ERROR: One of vbox*.ko modules wasn't built"
id='n398' href='#n398'>398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558