summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb6
-rw-r--r--recipes-demo-hmi/dashboard/dashboard_git.bb2
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb6
-rw-r--r--recipes-demo-hmi/hvac/hvac_git.bb5
-rw-r--r--recipes-demo-hmi/launcher/launcher_git.bb5
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb1
-rw-r--r--recipes-demo-hmi/messaging/messaging_git.bb1
-rw-r--r--recipes-demo-hmi/mixer/mixer_git.bb1
-rw-r--r--recipes-demo-hmi/navigation/navigation-demo_git.bb1
-rw-r--r--recipes-demo-hmi/navigation/ondemandnavi_git.bb2
-rw-r--r--recipes-demo-hmi/navigation/poiapp_git.bb2
-rw-r--r--recipes-demo-hmi/navigation/tbtnavi_git.bb1
-rw-r--r--recipes-demo-hmi/onscreenapp/onscreenapp_git.bb2
-rw-r--r--recipes-demo-hmi/phone/phone_git.bb1
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb2
-rw-r--r--recipes-demo-hmi/settings/settings_git.bb2
-rw-r--r--recipes-demo-hmi/taskmanager/taskmanager_git.bb1
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb4
-rw-r--r--recipes-platform/packagegroups/packagegroup-hmi-framework.bb6
19 files changed, 21 insertions, 30 deletions
diff --git a/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
index f98704eed..f73a97acb 100644
--- a/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
+++ b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
@@ -8,10 +8,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qtquickcontrols2 \
- qlibwindowmanager \
qlibhomescreen \
af-binder \
libqtappfw \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
@@ -27,7 +30,6 @@ OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel'
RDEPENDS_${PN} = " \
libqtappfw \
libafbwsc \
- qlibwindowmanager \
qlibhomescreen \
agl-service-voice-high-capabilities \
"
diff --git a/recipes-demo-hmi/dashboard/dashboard_git.bb b/recipes-demo-hmi/dashboard/dashboard_git.bb
index 822207b17..70a8793d2 100644
--- a/recipes-demo-hmi/dashboard/dashboard_git.bb
+++ b/recipes-demo-hmi/dashboard/dashboard_git.bb
@@ -13,7 +13,7 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native qtaglextras libqtappfw"
+DEPENDS += "qtquickcontrols2 qttools-native libqtappfw"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index a49c30508..44a0f524a 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -10,12 +10,14 @@ DEPENDS = "\
qtdeclarative \
qtquickcontrols2 \
agl-service-homescreen \
- agl-service-windowmanager \
agl-service-weather \
libqtappfw \
- qlibwindowmanager \
libhomescreen \
libafb-helpers-qt \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native
"
inherit qmake5 systemd pkgconfig aglwgt
diff --git a/recipes-demo-hmi/hvac/hvac_git.bb b/recipes-demo-hmi/hvac/hvac_git.bb
index 6091e51e2..5e36e2d41 100644
--- a/recipes-demo-hmi/hvac/hvac_git.bb
+++ b/recipes-demo-hmi/hvac/hvac_git.bb
@@ -14,8 +14,9 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2 libhomescreen \
- qlibwindowmanager qttools-native \
- qtaglextras libqtappfw"
+ qttools-native \
+ libqtappfw"
+
RDEPENDS_${PN} = "agl-service-hvac libqtappfw"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/launcher/launcher_git.bb b/recipes-demo-hmi/launcher/launcher_git.bb
index 8c3f72f68..5b1de0134 100644
--- a/recipes-demo-hmi/launcher/launcher_git.bb
+++ b/recipes-demo-hmi/launcher/launcher_git.bb
@@ -10,8 +10,11 @@ DEPENDS = "\
qtdeclarative \
qtquickcontrols2 \
qtwebsockets \
- qlibwindowmanager \
qlibhomescreen \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
"
inherit qmake5 systemd pkgconfig aglwgt
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
index 2e8468106..974b20275 100644
--- a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -17,7 +17,6 @@ DEPENDS += "qtquickcontrols2 \
qtwebsockets \
libqtappfw \
libhomescreen \
- qlibwindowmanager \
"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/messaging/messaging_git.bb b/recipes-demo-hmi/messaging/messaging_git.bb
index f6b545d62..d2e3ff80d 100644
--- a/recipes-demo-hmi/messaging/messaging_git.bb
+++ b/recipes-demo-hmi/messaging/messaging_git.bb
@@ -16,7 +16,6 @@ S = "${WORKDIR}/git"
DEPENDS += "qtquickcontrols2 \
libqtappfw \
libhomescreen \
- qlibwindowmanager \
"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/mixer/mixer_git.bb b/recipes-demo-hmi/mixer/mixer_git.bb
index 9524bed66..1e4a2717c 100644
--- a/recipes-demo-hmi/mixer/mixer_git.bb
+++ b/recipes-demo-hmi/mixer/mixer_git.bb
@@ -15,7 +15,6 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2 \
qtwebsockets \
- qtaglextras \
libafb-helpers-qt \
"
diff --git a/recipes-demo-hmi/navigation/navigation-demo_git.bb b/recipes-demo-hmi/navigation/navigation-demo_git.bb
index b1d0407f3..7f3fcdf10 100644
--- a/recipes-demo-hmi/navigation/navigation-demo_git.bb
+++ b/recipes-demo-hmi/navigation/navigation-demo_git.bb
@@ -17,7 +17,6 @@ RPROVIDES_${PN} = "virtual/navigation"
DEPENDS += "qtquickcontrols2 \
libhomescreen \
- qlibwindowmanager \
qtvirtualkeyboard \
qtlocation \
"
diff --git a/recipes-demo-hmi/navigation/ondemandnavi_git.bb b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
index c52655ef0..c06dcae22 100644
--- a/recipes-demo-hmi/navigation/ondemandnavi_git.bb
+++ b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
@@ -8,9 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS += "qtquickcontrols2 \
qlibhomescreen \
- qlibwindowmanager \
qtlocation \
- qtaglextras \
libqtappfw \
"
diff --git a/recipes-demo-hmi/navigation/poiapp_git.bb b/recipes-demo-hmi/navigation/poiapp_git.bb
index b8db9ac93..bd3fc64d2 100644
--- a/recipes-demo-hmi/navigation/poiapp_git.bb
+++ b/recipes-demo-hmi/navigation/poiapp_git.bb
@@ -7,7 +7,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
DEPENDS += "qtbase json-c \
- qlibwindowmanager libhomescreen \
+ libhomescreen \
libqtappfw \
"
diff --git a/recipes-demo-hmi/navigation/tbtnavi_git.bb b/recipes-demo-hmi/navigation/tbtnavi_git.bb
index a61f2c924..e27fe7359 100644
--- a/recipes-demo-hmi/navigation/tbtnavi_git.bb
+++ b/recipes-demo-hmi/navigation/tbtnavi_git.bb
@@ -14,7 +14,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
DEPENDS += "qtbase \
qtquickcontrols2 \
qlibhomescreen \
- qlibwindowmanager \
qtlocation \
libqtappfw \
"
diff --git a/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb b/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
index ae905ea60..b0f63d162 100644
--- a/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
+++ b/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen libwindowmanager qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/phone/phone_git.bb b/recipes-demo-hmi/phone/phone_git.bb
index cab30ea6b..a8781852d 100644
--- a/recipes-demo-hmi/phone/phone_git.bb
+++ b/recipes-demo-hmi/phone/phone_git.bb
@@ -16,7 +16,6 @@ S = "${WORKDIR}/git"
DEPENDS += "qtquickcontrols2 \
libqtappfw \
libhomescreen \
- qlibwindowmanager \
gstreamer1.0 \
"
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
index 3a89af588..7b0934faa 100644
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "libhomescreen qlibwindowmanager libqtappfw"
+DEPENDS += "libhomescreen libqtappfw"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/settings/settings_git.bb b/recipes-demo-hmi/settings/settings_git.bb
index 17b83dc9f..776c764ca 100644
--- a/recipes-demo-hmi/settings/settings_git.bb
+++ b/recipes-demo-hmi/settings/settings_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
-DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+DEPENDS += "libhomescreen qtvirtualkeyboard"
# runtime dependencies
RDEPENDS_${PN} += " \
diff --git a/recipes-demo-hmi/taskmanager/taskmanager_git.bb b/recipes-demo-hmi/taskmanager/taskmanager_git.bb
index 13f16fca5..68965eb55 100644
--- a/recipes-demo-hmi/taskmanager/taskmanager_git.bb
+++ b/recipes-demo-hmi/taskmanager/taskmanager_git.bb
@@ -18,7 +18,6 @@ DEPENDS += "qtquickcontrols2 \
qtcharts \
libqtappfw \
libhomescreen \
- qlibwindowmanager \
"
inherit qmake5 aglwgt
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index fc0bbfa6e..812139b2e 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -37,9 +37,7 @@ AGL_APPS = " \
virtual/mixer \
"
-QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
-#NOTE: removed libqtappfw from QTAGLEXTRAS as it is no longer
-# necessary due to replacement by individual recipe RDEPENDS.
+QTAGLEXTRAS = " libqtappfw"
# add support for websocket in Qt and QML
QTAGLEXTRAS_append = " qtwebsockets qtwebsockets-qmlplugins"
diff --git a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
index f7de02c90..6e0749309 100644
--- a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -16,22 +16,16 @@ PACKAGES = "\
"
RDEPENDS_${PN} = " \
- agl-service-windowmanager \
agl-service-homescreen \
homescreen \
- libwindowmanager \
- qlibwindowmanager \
libhomescreen \
qlibhomescreen \
- runxdg \
hmi-debug \
launcher \
"
-
# NOTE: Currently no coverage versions of these widgets, they should
# be added here when available.
RDEPENDS_${PN}-devel = " \
- agl-service-windowmanager-dbg \
agl-service-homescreen-dbg \
homescreen-dbg \
launcher-dbg \