summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/html5-hvac/files/webapps-hvac.desktop11
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb38
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
3 files changed, 50 insertions, 0 deletions
diff --git a/recipes-demo/html5-hvac/files/webapps-hvac.desktop b/recipes-demo/html5-hvac/files/webapps-hvac.desktop
new file mode 100644
index 00000000..88b13938
--- /dev/null
+++ b/recipes-demo/html5-hvac/files/webapps-hvac.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 HVAC
+Comment=HVAC
+GenericName=HVAC
+Exec=env AFM_ID=webapps-hvac AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-hvac/ /usr/bin/WebAppMgr
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
new file mode 100644
index 00000000..85fed294
--- /dev/null
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "AGL HTML5 HVAC Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-hvac/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://webapps-hvac.desktop \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS = "nodejs-native"
+
+do_compile() {
+ bldcmd=${S}/autobuild/agl/autobuild
+ cd ${S}
+ $bldcmd build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/webapps-hvac.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES_${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${APPLICATIONS_DIR} \
+" \ No newline at end of file
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index adc08bee..5342f078 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -41,6 +41,7 @@ RDEPENDS:${PN}-devel = " \
# TODO(jdapena): replace this with HTML5 apps.
AGL_APPS = " \
dashboard \
+ html5-hvac \
hvac \
ondemandnavi \
settings \