summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-config/dev-mapping
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/recipes-config/dev-mapping')
-rw-r--r--_to_remove/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci7
-rw-r--r--_to_remove/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb18
-rw-r--r--_to_remove/recipes-config/dev-mapping/dev-mapping-demo/dev-mapping.conf.demo7
-rw-r--r--_to_remove/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb18
-rw-r--r--_to_remove/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default7
-rw-r--r--_to_remove/recipes-config/dev-mapping/dev-mapping_0.1.bb18
6 files changed, 75 insertions, 0 deletions
diff --git a/_to_remove/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci b/_to_remove/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
new file mode 100644
index 000000000..bd5c2135a
--- /dev/null
+++ b/_to_remove/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="vcan0"
+ls="vcan0"
+j1939="vcan0"
diff --git a/_to_remove/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/_to_remove/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644
index 000000000..7b40e40c6
--- /dev/null
+++ b/_to_remove/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES:${PN} = "virtual/low-can-dev-mapping"
diff --git a/_to_remove/recipes-config/dev-mapping/dev-mapping-demo/dev-mapping.conf.demo b/_to_remove/recipes-config/dev-mapping/dev-mapping-demo/dev-mapping.conf.demo
new file mode 100644
index 000000000..1fd12ad03
--- /dev/null
+++ b/_to_remove/recipes-config/dev-mapping/dev-mapping-demo/dev-mapping.conf.demo
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="can0"
+ls="sllin0"
+j1939="can0"
diff --git a/_to_remove/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb b/_to_remove/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
new file mode 100644
index 000000000..23fdc078a
--- /dev/null
+++ b/_to_remove/recipes-config/dev-mapping/dev-mapping-demo_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding for the AGL demo setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.demo"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.demo ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES:${PN} = "virtual/low-can-dev-mapping"
diff --git a/_to_remove/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default b/_to_remove/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
new file mode 100644
index 000000000..8519a5873
--- /dev/null
+++ b/_to_remove/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="can0"
+ls="can0"
+j1939="can0"
diff --git a/_to_remove/recipes-config/dev-mapping/dev-mapping_0.1.bb b/_to_remove/recipes-config/dev-mapping/dev-mapping_0.1.bb
new file mode 100644
index 000000000..f880d39d8
--- /dev/null
+++ b/_to_remove/recipes-config/dev-mapping/dev-mapping_0.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL Device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding by example."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.default"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.default ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES:${PN} = "virtual/low-can-dev-mapping"