summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend')
-rw-r--r--_to_remove/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend35
1 files changed, 35 insertions, 0 deletions
diff --git a/_to_remove/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend b/_to_remove/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
new file mode 100644
index 000000000..b592e822b
--- /dev/null
+++ b/_to_remove/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
@@ -0,0 +1,35 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/bluez-alsa:"
+
+SRC_URI += "\
+ file://0001-utils-add-a-gstreamer-helper-application-for-interco.patch \
+ file://bluealsa-gst-helper@.service \
+ "
+
+PACKAGECONFIG += "gsthelper"
+PACKAGECONFIG[gsthelper] = "--enable-gsthelper, --disable-gsthelper, gstreamer1.0"
+
+do_install:append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ # install the service file
+ mkdir -p ${D}${systemd_system_unitdir}/
+ install -m 0644 ${WORKDIR}/bluealsa-gst-helper@.service ${D}${systemd_system_unitdir}/bluealsa-gst-helper@.service
+
+ # enable the helper to start together with afm-user-session
+ mkdir -p ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
+ ln -sf ../bluealsa-gst-helper@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/bluealsa-gst-helper@.service
+ fi
+}
+
+PACKAGES =+ "${PN}-pipewire"
+
+FILES:${PN}-pipewire = "\
+ ${bindir}/bluealsa-gst-helper \
+ ${systemd_system_unitdir}/bluealsa-gst-helper@.service \
+ ${systemd_system_unitdir}/afm-user-session@.target.wants/bluealsa-gst-helper@.service \
+ "
+RDEPENDS:${PN}-pipewire += "\
+ bluez-alsa \
+ pipewire \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-pipewire \
+ "