summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/cluster-receiver/cluster-receiver_git.bb
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/recipes-demo/cluster-receiver/cluster-receiver_git.bb')
-rw-r--r--_to_remove/recipes-demo/cluster-receiver/cluster-receiver_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/cluster-receiver/cluster-receiver_git.bb b/_to_remove/recipes-demo/cluster-receiver/cluster-receiver_git.bb
new file mode 100644
index 000000000..7028d5fc1
--- /dev/null
+++ b/_to_remove/recipes-demo/cluster-receiver/cluster-receiver_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Instrument Cluster Receiver application"
+DESCRIPTION = "AGL demonstration instrument cluster remote display application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+DEPENDS = " \
+ wayland wayland-native \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad agl-compositor \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig aglwgt
+
+RDEPENDS:${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+"