summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/mixer/mixer_git.bb
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/recipes-demo/mixer/mixer_git.bb')
-rw-r--r--_to_remove/recipes-demo/mixer/mixer_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/mixer/mixer_git.bb b/_to_remove/recipes-demo/mixer/mixer_git.bb
new file mode 100644
index 000000000..c99c04420
--- /dev/null
+++ b/_to_remove/recipes-demo/mixer/mixer_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Mixer application"
+DESCRIPTION = "AGL demonstration Mixer application for control of PipeWire mixer elements"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+ qtquickcontrols2 \
+ qtwebsockets \
+ libafb-helpers-qt \
+"
+
+PROVIDES += "virtual/mixer"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS:${PN} = "agl-service-audiomixer"
+RPROVIDES:${PN} += "virtual/mixer"