summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/navigation/poiapp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/recipes-demo/navigation/poiapp_git.bb')
-rw-r--r--_to_remove/recipes-demo/navigation/poiapp_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/navigation/poiapp_git.bb b/_to_remove/recipes-demo/navigation/poiapp_git.bb
new file mode 100644
index 000000000..08e174f74
--- /dev/null
+++ b/_to_remove/recipes-demo/navigation/poiapp_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "AGL Reference POI application."
+DESCRIPTION = "This application provides the function of destination search to AGL. It uses the API provided by AGL Reference Navigation. This application uses yelp WebAPI."
+HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION = "apps"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
+
+DEPENDS = " \
+ qtbase \
+ json-c \
+ libhomescreen \
+ libqtappfw \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS:${PN} = "qtbase libqtappfw"