summaryrefslogtreecommitdiffstats
path: root/_to_remove/recipes-demo/waltham-receiver/waltham-receiver_git.bb
diff options
context:
space:
mode:
Diffstat (limited to '_to_remove/recipes-demo/waltham-receiver/waltham-receiver_git.bb')
-rw-r--r--_to_remove/recipes-demo/waltham-receiver/waltham-receiver_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/_to_remove/recipes-demo/waltham-receiver/waltham-receiver_git.bb b/_to_remove/recipes-demo/waltham-receiver/waltham-receiver_git.bb
new file mode 100644
index 000000000..75ada4dd1
--- /dev/null
+++ b/_to_remove/recipes-demo/waltham-receiver/waltham-receiver_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Waltham Receiver application"
+DESCRIPTION = "AGL demonstration Waltham receiver interactive remote display application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+DEPENDS = " \
+ waltham wayland wayland-native \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig aglwgt
+
+RDEPENDS:${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+ waltham \
+"