summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo/recipes-demo/webapp-samples
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-html5-demo/recipes-demo/webapp-samples')
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc23
9 files changed, 135 insertions, 0 deletions
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json
new file mode 100644
index 00000000..76fdd9e3
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-aquarium",
+ "title": "Aquarium",
+ "description": "HTML5 WebGL Aquarium sample",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "aquarium.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json
new file mode 100644
index 00000000..c1c960db
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-examples",
+ "title": "Examples",
+ "description": "HTML5 examples",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "index.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json
new file mode 100644
index 00000000..f5e1d808
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-jitsi",
+ "title": "Jitsi",
+ "description": "HTML5 Jitsi sample",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "index.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json
new file mode 100644
index 00000000..f844bf7a
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-youtube",
+ "title": "Youtube",
+ "description": "HTML5 Youtube sample",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "index.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
new file mode 100644
index 00000000..0afc8514
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Aquarium Demo"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
+APPINFO_FILE = "appinfo-aquarium.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-aquarium"
+AGL_APP_NAME = "Aquarium"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb
new file mode 100644
index 00000000..c2b131af
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Examples"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-examples.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-examples"
+AGL_APP_NAME = "Examples"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/examples/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb
new file mode 100644
index 00000000..e382cb03
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Jitsi"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-jitsi.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-jitsi"
+AGL_APP_NAME = "Jitsi"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/jitsi/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb
new file mode 100644
index 00000000..44a96440
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Youtube"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-youtube.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-youtube"
+AGL_APP_NAME = "Youtube"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/youtube/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
new file mode 100644
index 00000000..1a74a46c
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
@@ -0,0 +1,23 @@
+HOMEPAGE = "https://github.com/AGL-web-applications/webapp-samples"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://github.com/AGL-web-applications/webapp-samples.git;protocol=https;branch=master \
+ file://${APPINFO_FILE} \
+"
+SRCREV = "b24a62cc524bdec98a61acc03fc53cbab24c1571"
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install ${WORKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+"