summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo/recipes-demo
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-html5-demo/recipes-demo')
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-background/html5-background_git.bb41
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-dashboard/html5-dashboard_git.bb39
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-homescreen/files/homescreen.service16
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb45
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-hvac/html5-hvac_git.bb40
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-launcher/html5-launcher_git.bb42
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb39
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-mixer/html5-mixer_git.bb40
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-settings/html5-settings_git.bb39
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json11
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb17
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc23
18 files changed, 476 insertions, 0 deletions
diff --git a/meta-agl-html5-demo/recipes-demo/html5-background/html5-background_git.bb b/meta-agl-html5-demo/recipes-demo/html5-background/html5-background_git.bb
new file mode 100644
index 00000000..9c35050f
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-background/html5-background_git.bb
@@ -0,0 +1,41 @@
+SUMMARY = "AGL HTML5 Background"
+HOMEPAGE = "https://github.com/AGL-web-applications/background"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
+"
+SRCREV = "aa7e2a81e91ed076c0bc9ba07db5aee0f34668df"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-${BPN}"
+AGL_APP_NAME = "HTML5 Background"
+
+DEPENDS = "nodejs-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
+
+RCONFLICTS:${PN} = "homescreen"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-dashboard/html5-dashboard_git.bb b/meta-agl-html5-demo/recipes-demo/html5-dashboard/html5-dashboard_git.bb
new file mode 100644
index 00000000..b9037753
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-dashboard/html5-dashboard_git.bb
@@ -0,0 +1,39 @@
+SUMMARY = "AGL HTML5 dashboard Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=master \
+"
+SRCREV = "38befd7704f64781bf4bce85fd9b2cdffc7845fa"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-dashboard"
+AGL_APP_NAME = "HTML5 Dashboard"
+
+DEPENDS = "nodejs-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-homescreen/files/homescreen.service b/meta-agl-html5-demo/recipes-demo/html5-homescreen/files/homescreen.service
new file mode 100644
index 00000000..b8d34caa
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-homescreen/files/homescreen.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=AGL Homescreen
+Requires=WebAppMgr.service dbus.service
+After=WebAppMgr.service dbus.service
+
+[Service]
+Type=simple
+User=agl-driver
+EnvironmentFile=-/etc/default/WebAppMgr.env
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
+ExecStartPre=sleep 5
+ExecStart=/usr/bin/WebAppMgrCli --appid=homescreen --app-install-dir=/usr/lib/wam_apps/html5-homescreen/
+Restart=on-failure
+
+[Install]
+WantedBy=graphical.target
diff --git a/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
new file mode 100644
index 00000000..8638c758
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -0,0 +1,45 @@
+SUMMARY = "AGL HTML5 Homescreen"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-homescreen/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
+ file://homescreen.service \
+"
+SRCREV = "32098508fa7375690ea1b8dc9da4e7ca641494c1"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+inherit systemd
+
+DEPENDS = "nodejs-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+SYSTEMD_SERVICE:${PN} = "homescreen.service"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -D -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${systemd_system_unitdir} \
+"
+
+RCONFLICTS:${PN} = "homescreen flutter-homescreen"
+RDEPENDS:${PN} = "applaunchd html5-background"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-hvac/html5-hvac_git.bb b/meta-agl-html5-demo/recipes-demo/html5-hvac/html5-hvac_git.bb
new file mode 100644
index 00000000..785d9b68
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -0,0 +1,40 @@
+SUMMARY = "AGL HTML5 HVAC Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-hvac/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
+"
+SRCREV = "c323ab8fde212120d8d1914d453afeb55b3576e5"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-hvac"
+AGL_APP_NAME = "HTML5 HVAC"
+
+DEPENDS = "nodejs-native protobuf-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run generate-grpc
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-launcher/html5-launcher_git.bb b/meta-agl-html5-demo/recipes-demo/html5-launcher/html5-launcher_git.bb
new file mode 100644
index 00000000..f717f9e9
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -0,0 +1,42 @@
+SUMMARY = "AGL HTML5 Launcher Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-launcher/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
+"
+SRCREV = "ccdd59db7dc073eee0a35d0318640d9833824073"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "launcher"
+AGL_APP_NAME = "HTML5 Launcher"
+
+DEPENDS = "nodejs-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
+
+RCONFLICTS:${PN} = "launcher flutter-homescreen"
+RDEPENDS:${PN} = "applaunchd"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb b/meta-agl-html5-demo/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
new file mode 100644
index 00000000..b7b25c27
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -0,0 +1,39 @@
+SUMMARY = "AGL HTML5 media player Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=master \
+"
+SRCREV = "b87776912cc31c976415ceb49e7551f500e0975b"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-mediaplayer"
+AGL_APP_NAME = "HTML5 Media Player"
+
+DEPENDS = "nodejs-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-mixer/html5-mixer_git.bb b/meta-agl-html5-demo/recipes-demo/html5-mixer/html5-mixer_git.bb
new file mode 100644
index 00000000..c7957b3f
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-mixer/html5-mixer_git.bb
@@ -0,0 +1,40 @@
+SUMMARY = "AGL HTML5 mixer Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mixer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
+"
+SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-mixer"
+AGL_APP_NAME = "HTML5 Mixer"
+
+DEPENDS = "nodejs-native protobuf-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run generate-grpc
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/meta-agl-html5-demo/recipes-demo/html5-settings/html5-settings_git.bb b/meta-agl-html5-demo/recipes-demo/html5-settings/html5-settings_git.bb
new file mode 100644
index 00000000..a5ec6252
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/html5-settings/html5-settings_git.bb
@@ -0,0 +1,39 @@
+SUMMARY = "AGL HTML5 settings Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-settings/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=master \
+"
+SRCREV = "69af4d9b9b209fcb33ef9071ddfa8561106044c2"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-settings"
+AGL_APP_NAME = "HTML5 Settings"
+
+DEPENDS = "nodejs-native icu-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json
new file mode 100644
index 00000000..76fdd9e3
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-aquarium.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-aquarium",
+ "title": "Aquarium",
+ "description": "HTML5 WebGL Aquarium sample",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "aquarium.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json
new file mode 100644
index 00000000..c1c960db
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-examples.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-examples",
+ "title": "Examples",
+ "description": "HTML5 examples",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "index.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json
new file mode 100644
index 00000000..f5e1d808
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-jitsi.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-jitsi",
+ "title": "Jitsi",
+ "description": "HTML5 Jitsi sample",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "index.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json
new file mode 100644
index 00000000..f844bf7a
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/files/appinfo-youtube.json
@@ -0,0 +1,11 @@
+{
+ "id": "webapps-youtube",
+ "title": "Youtube",
+ "description": "HTML5 Youtube sample",
+ "version": "0.0.0",
+ "vendor": "Igalia, S.L.",
+ "type": "web",
+ "main": "index.html",
+ "uiRevision": "2",
+ "icon": "icon.svg"
+}
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
new file mode 100644
index 00000000..0afc8514
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-aquarium_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Aquarium Demo"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
+APPINFO_FILE = "appinfo-aquarium.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-aquarium"
+AGL_APP_NAME = "Aquarium"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb
new file mode 100644
index 00000000..c2b131af
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-examples_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Examples"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-examples.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-examples"
+AGL_APP_NAME = "Examples"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/examples/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb
new file mode 100644
index 00000000..e382cb03
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-jitsi_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Jitsi"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-jitsi.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-jitsi"
+AGL_APP_NAME = "Jitsi"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/jitsi/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb
new file mode 100644
index 00000000..44a96440
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/html5-youtube_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Youtube"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-youtube.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-youtube"
+AGL_APP_NAME = "Youtube"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/youtube/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
new file mode 100644
index 00000000..1a74a46c
--- /dev/null
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
@@ -0,0 +1,23 @@
+HOMEPAGE = "https://github.com/AGL-web-applications/webapp-samples"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://github.com/AGL-web-applications/webapp-samples.git;protocol=https;branch=master \
+ file://${APPINFO_FILE} \
+"
+SRCREV = "b24a62cc524bdec98a61acc03fc53cbab24c1571"
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install ${WORKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+"