aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-can-low-level
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-apis/agl-service-can-low-level')
-rw-r--r--recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb23
-rw-r--r--recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend4
-rw-r--r--recipes-apis/agl-service-can-low-level/files/run-ptest3
3 files changed, 28 insertions, 2 deletions
diff --git a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
new file mode 100644
index 00000000..83f6c1e7
--- /dev/null
+++ b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Low level CAN service"
+DESCRIPTION = "AGL Service application for read and decode CAN messages"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/low-level-can-service"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS = "libafb-helpers libappcontroller"
+
+inherit cmake aglwgt pkgconfig ptest
+
+# For now, just enable J1939 on the qemu platforms where we know the
+# linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
+AGLWGT_CMAKE_CONFIGURE_ARGS_append_qemuall = " -DWITH_FEATURE_J1939=ON"
+
+RDEPENDS_${PN} = "virtual/low-can-dev-mapping"
diff --git a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend
index 4f282104..cc198c1c 100644
--- a/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend
+++ b/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bbappend
@@ -1,10 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://can-dev-mapping-helper.conf"
+SRC_URI_append = " file://can-dev-mapping-helper.conf"
do_install_append() {
install -D -m 0644 ${WORKDIR}/can-dev-mapping-helper.conf \
${D}${sysconfdir}/systemd/system/afm-service-agl-service-can-low-level-.service.d/can-dev-mapping-helper.conf
}
-RDEPENDS_${PN} += "can-dev-mapping-helper"
+RDEPENDS_${PN}_append = " can-dev-mapping-helper"
diff --git a/recipes-apis/agl-service-can-low-level/files/run-ptest b/recipes-apis/agl-service-can-low-level/files/run-ptest
new file mode 100644
index 00000000..cc9c4136
--- /dev/null
+++ b/recipes-apis/agl-service-can-low-level/files/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+afm-test /usr/AGL/apps/testwgt/low-can-service-test.wgt