summaryrefslogtreecommitdiffstats
path: root/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb')
-rw-r--r--recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
new file mode 100644
index 00000000..c54e28cc
--- /dev/null
+++ b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "ambdbusaccess"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad \
+ file://ambdbusaccess.cpp;startline=1;endline=5;md5=0ba6897a99e9332dae1891b4ccf78de3 \
+ "
+
+SRC_URI = "file://* \
+ "
+S = "${WORKDIR}"
+
+DEPENDS = "qtdeclarative qtbase"
+RDEPENDS_${PN} = "automotive-message-broker"
+
+RPROVIDES_${PN} = "ambdbusaccess"
+
+inherit qmake5
+
+do_install () {
+ mkdir -p ${D}/usr/lib/qt5/qml/Automotive/
+ cp ambdbusaccess ${D}/usr/lib/qt5/qml/Automotive/
+}
+
+FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"
+FILES_${PN}-dbg += "${libdir}/qt5/qml/Automotive/.debug"
+