summaryrefslogtreecommitdiffstats
path: root/recipes-automotive
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-automotive')
-rw-r--r--recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb4
-rw-r--r--recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb6
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
index c54e28cc..e804113d 100644
--- a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
+++ b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
@@ -17,8 +17,8 @@ RPROVIDES_${PN} = "ambdbusaccess"
inherit qmake5
do_install () {
- mkdir -p ${D}/usr/lib/qt5/qml/Automotive/
- cp ambdbusaccess ${D}/usr/lib/qt5/qml/Automotive/
+ install -d ${D}${libdir}/qt5/qml/Automotive/
+ install -m 0755 ambdbusaccess ${D}${libdir}/qt5/qml/Automotive/
}
FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"
diff --git a/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb b/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb
index 8058bdbf..7f98fb39 100644
--- a/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb
+++ b/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb
@@ -18,9 +18,9 @@ RDEPENDS_${PN} = "automotive-message-broker ambdbusaccess"
inherit qmake5
do_install () {
- mkdir -p ${D}/usr/lib/qt5/qml/Automotive/ClimateControl/
- cp libClimateControl.so ${D}/usr/lib/qt5/qml/Automotive/ClimateControl/
- cp qmldir ${D}/usr/lib/qt5/qml/Automotive/ClimateControl/
+ install -d ${D}${libdir}/qt5/qml/Automotive/ClimateControl/
+ install -m 0755 libClimateControl.so ${D}${libdir}/qt5/qml/Automotive/ClimateControl/
+ install -m 0644 qmldir ${D}${libdir}/qt5/qml/Automotive/ClimateControl/
}
FILES_${PN} += "${libdir}/qt5/qml/Automotive/ClimateControl/libClimateControl.so \