summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/bluez-alsa
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/bluez-alsa')
-rw-r--r--recipes-connectivity/bluez-alsa/bluez-alsa_git.bb8
-rw-r--r--recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend8
2 files changed, 8 insertions, 8 deletions
diff --git a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
index 010329ee..27f462a8 100644
--- a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
+++ b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bb
@@ -22,21 +22,21 @@ inherit autotools pkgconfig
inherit systemd
SYSTEMD_AUTO_ENABLE = "enable"
-SYSTEMD_SERVICE_${PN} = "bluez-alsa.service"
+SYSTEMD_SERVICE:${PN} = "bluez-alsa.service"
PACKAGECONFIG += "ofono"
# enable debug tools in devel images
PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
PACKAGECONFIG[rfcomm] = "--enable-rfcomm, --disable-rfcomm,"
-PACKAGECONFIG_append_agl-devel = " hcitop rfcomm"
+PACKAGECONFIG:append:agl-devel = " hcitop rfcomm"
-do_install_append () {
+do_install:append () {
install -d ${D}${base_libdir}/systemd/system
install -m 0644 ${WORKDIR}/bluez-alsa.service ${D}${base_libdir}/systemd/system
}
-FILES_${PN} += "\
+FILES:${PN} += "\
${datadir}/alsa/alsa.conf.d/20-bluealsa.conf\
${libdir}/alsa-lib/libasound_module_ctl_bluealsa.so\
${libdir}/alsa-lib/libasound_module_pcm_bluealsa.so\
diff --git a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
index bcb47888..b592e822 100644
--- a/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
+++ b/recipes-connectivity/bluez-alsa/bluez-alsa_git.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/bluez-alsa:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/bluez-alsa:"
SRC_URI += "\
file://0001-utils-add-a-gstreamer-helper-application-for-interco.patch \
@@ -8,7 +8,7 @@ SRC_URI += "\
PACKAGECONFIG += "gsthelper"
PACKAGECONFIG[gsthelper] = "--enable-gsthelper, --disable-gsthelper, gstreamer1.0"
-do_install_append() {
+do_install:append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
# install the service file
mkdir -p ${D}${systemd_system_unitdir}/
@@ -22,12 +22,12 @@ do_install_append() {
PACKAGES =+ "${PN}-pipewire"
-FILES_${PN}-pipewire = "\
+FILES:${PN}-pipewire = "\
${bindir}/bluealsa-gst-helper \
${systemd_system_unitdir}/bluealsa-gst-helper@.service \
${systemd_system_unitdir}/afm-user-session@.target.wants/bluealsa-gst-helper@.service \
"
-RDEPENDS_${PN}-pipewire += "\
+RDEPENDS:${PN}-pipewire += "\
bluez-alsa \
pipewire \
gstreamer1.0-plugins-base \