summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/cannelloni
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/cannelloni')
-rw-r--r--recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch24
-rw-r--r--recipes-connectivity/cannelloni/cannelloni_%.bbappend1
-rw-r--r--recipes-connectivity/cannelloni/cannelloni_agldemo.inc2
-rw-r--r--recipes-connectivity/cannelloni/cannelloni_git.bb15
4 files changed, 3 insertions, 39 deletions
diff --git a/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch b/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch
deleted file mode 100644
index b5e59e6e..00000000
--- a/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From f3b356b1ecd6c5401537f593ce373a5b76eb8a9d Mon Sep 17 00:00:00 2001
-From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-Date: Tue, 17 Nov 2020 16:06:20 +0100
-Subject: [PATCH] Fix compilation on latest gcc versions
-
-Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
----
- CMakeLists.txt | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 51fa256..7e977d1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,7 +6,8 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
- # Options
- option(SCTP_SUPPORT "SCTP_SUPPORT" ON)
-
--set(CMAKE_CXX_FLAGS -Wall)
-+#set(CMAKE_CXX_FLAGS -Wall)
-+set(CMAKE_CXX_STANDARD 11)
-
- if(SCTP_SUPPORT)
- include(FindSCTP)
diff --git a/recipes-connectivity/cannelloni/cannelloni_%.bbappend b/recipes-connectivity/cannelloni/cannelloni_%.bbappend
new file mode 100644
index 00000000..4619406a
--- /dev/null
+++ b/recipes-connectivity/cannelloni/cannelloni_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'cannelloni_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/cannelloni/cannelloni_agldemo.inc b/recipes-connectivity/cannelloni/cannelloni_agldemo.inc
new file mode 100644
index 00000000..c83d535a
--- /dev/null
+++ b/recipes-connectivity/cannelloni/cannelloni_agldemo.inc
@@ -0,0 +1,2 @@
+PV = "1.0.0+git${SRCPV}"
+SRCREV = "071d2d0a2b7997d697fa1228423b329f817a237a"
diff --git a/recipes-connectivity/cannelloni/cannelloni_git.bb b/recipes-connectivity/cannelloni/cannelloni_git.bb
deleted file mode 100644
index e4a4fa79..00000000
--- a/recipes-connectivity/cannelloni/cannelloni_git.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "A SocketCAN over Ethernet tunnel"
-HOMEPAGE = "https://github.com/mguentner/cannelloni"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https;branch=master \
- file://0001-Fix-compilation-on-latest-gcc-versions.patch \
- "
-
-PV = "1.0.0+git${SRCPV}"
-SRCREV = "aa0f0ecba2b8be0ea7ddd9952e719449a75330ec"
-
-S = "${WORKDIR}/git"
-
-inherit cmake