summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb')
-rw-r--r--recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb b/recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb
index 90f5ff1cd..ae99006c5 100644
--- a/recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb
+++ b/recipes-connectivity/kuksa-val/can-dev-helper_1.0.bb
@@ -6,6 +6,9 @@ SRC_URI = "file://can-dev-helper.service \
file://can-dev-helper.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -14,8 +17,8 @@ do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
- install -D -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
}
FILES:${PN} += "${systemd_system_unitdir}"