summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/vss/vss-tools_3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/vss/vss-tools_3.1.bb')
-rw-r--r--recipes-connectivity/vss/vss-tools_3.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-connectivity/vss/vss-tools_3.1.bb b/recipes-connectivity/vss/vss-tools_3.1.bb
new file mode 100644
index 00000000..b681d8dc
--- /dev/null
+++ b/recipes-connectivity/vss/vss-tools_3.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "COVESA Vehicle Signal Specification tooling."
+HOMEPAGE = "https://github.com/COVESA/vss-tools"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+SRC_URI = "git://github.com/COVESA/vss-tools.git;protocol=https;branch=master"
+SRCREV = "97148190d0f84bedfc933b8bc4391c0a7e7a099b"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-ctypes \
+ python3-email \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-pkg-resources \
+ python3-anytree \
+ python3-deprecation \
+ python3-graphql-core \
+ python3-pyyaml \
+ python3-six \
+"
+
+BBCLASSEXTEND += "native nativesdk"