summaryrefslogtreecommitdiffstats
path: root/recipes-core/psplash/psplash-portrait-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/psplash/psplash-portrait-config.bb')
-rw-r--r--recipes-core/psplash/psplash-portrait-config.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
index 7afee442c..8b32dc2dd 100644
--- a/recipes-core/psplash/psplash-portrait-config.bb
+++ b/recipes-core/psplash/psplash-portrait-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-portrait.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"