summaryrefslogtreecommitdiffstats
path: root/recipes-core/psplash
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/psplash')
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb5
-rw-r--r--recipes-core/psplash/psplash-portrait-config.bb5
-rw-r--r--recipes-core/psplash/psplash_agldemo.inc4
3 files changed, 10 insertions, 4 deletions
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
index f11b255da..0bc067cf0 100644
--- a/recipes-core/psplash/psplash-inverted-config.bb
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-inverted.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
index 7afee442c..8b32dc2dd 100644
--- a/recipes-core/psplash/psplash-portrait-config.bb
+++ b/recipes-core/psplash/psplash-portrait-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-portrait.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash_agldemo.inc b/recipes-core/psplash/psplash_agldemo.inc
index cc5b5b7b6..93d4b0583 100644
--- a/recipes-core/psplash/psplash_agldemo.inc
+++ b/recipes-core/psplash/psplash_agldemo.inc
@@ -8,13 +8,13 @@ SRC_URI:append = " \
SPLASH_IMAGES = "file://psplash-poky-img.h;outsuffix=default"
do_configure:append () {
- cp -f ${WORKDIR}/psplash-colors.h ${S}
+ cp -f ${UNPACKDIR}/psplash-colors.h ${S}
}
do_install:append () {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"