summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/psplash/files/psplash-inverted.conf2
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb20
-rw-r--r--recipes-core/udev/output-udev-conf/91-output.rules4
3 files changed, 24 insertions, 2 deletions
diff --git a/recipes-core/psplash/files/psplash-inverted.conf b/recipes-core/psplash/files/psplash-inverted.conf
new file mode 100644
index 00000000..440db891
--- /dev/null
+++ b/recipes-core/psplash/files/psplash-inverted.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=PSPLASH_ANGLE_ARGS='--angle 180'
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
new file mode 100644
index 00000000..f11b255d
--- /dev/null
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Systemd unit override for psplash inverted mode for the AGL Demonstrator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://psplash-inverted.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "psplash"
diff --git a/recipes-core/udev/output-udev-conf/91-output.rules b/recipes-core/udev/output-udev-conf/91-output.rules
index 89af4645..9b09a7ca 100644
--- a/recipes-core/udev/output-udev-conf/91-output.rules
+++ b/recipes-core/udev/output-udev-conf/91-output.rules
@@ -1,6 +1,6 @@
# Associate all input devices with the first display
#
# NOTE: Can be more selective with something like:
-# SUBSYSTEM=="input", ATTRS{idVendor}=="*", ATTRS{idProduct}=="004a", OWNER="display", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
+# SUBSYSTEM=="input", ATTRS{idVendor}=="*", ATTRS{idProduct}=="004a", OWNER="agl-driver", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
#
-SUBSYSTEM=="input", OWNER="display", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
+SUBSYSTEM=="input", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"