aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/CES2017-demo/CES2017-demo.bb')
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb42
1 files changed, 9 insertions, 33 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 514aea0b..7d64f83e 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -10,6 +10,8 @@ PN = "ces2017-demo"
inherit qmake5
DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
+inherit aglwgt
+
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
# ALS, CES, FOSDEM available
@@ -39,6 +41,8 @@ RDEPENDS_${PN} += " \
"
do_install_prepend() {
+ mkdir -p ${B}/package
+
echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"controls\" version=\"0.1\"> \
<name>Controls</name> \
@@ -51,9 +55,7 @@ do_install_prepend() {
" > ${B}/apps/Controls/config.xml
cd ${B}/apps/Controls/
- zip controls.wgt config.xml controls
-
-
+ zip ${B}/package/controls.wgt config.xml controls
echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"dashboard\" version=\"0.1\"> \
@@ -67,8 +69,7 @@ do_install_prepend() {
" > ${B}/apps/Dashboard/config.xml
cd ${B}/apps/Dashboard/
- zip dashboard.wgt config.xml dashboard
-
+ zip ${B}/package/dashboard.wgt config.xml dashboard
echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
@@ -83,7 +84,7 @@ do_install_prepend() {
" > ${B}/apps/Phone/config.xml
cd ${B}/apps/Phone/
- zip phone.wgt config.xml phone
+ zip ${B}/package/phone.wgt config.xml phone
@@ -99,40 +100,17 @@ do_install_prepend() {
" > ${B}/apps/Radio/config.xml
cd ${B}/apps/Radio/
- zip radio.wgt config.xml radio
-
-
- cat > ${B}/apps/installAllApps.sh <<-EOF
- #!/bin/sh
- cd /usr/AGL/apps
- for file in \`find . -maxdepth 1 -name '*.wgt'\`; do
-
- /usr/bin/afm-util install \$file
- done
- sync
-
- #it's Workaround
- cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'
- cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus'
- EOF
+ zip ${B}/package/radio.wgt config.xml radio
+
}
do_install() {
- install -d ${D}/usr/AGL/${PN}
- install -d ${D}/usr/AGL/apps
- install -m 0644 ${B}/apps/Controls/controls.wgt ${D}/usr/AGL/apps/
- install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/apps/
- install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/apps/
- install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/apps/
install -d ${D}/home/root/app-data/radio
install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
- install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/apps/
- ln -sf ../apps/installAllApps.sh ${D}/usr/AGL/${PN}/installAllApps.sh
-
install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/qmldir ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/ImageButton.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
@@ -162,8 +140,6 @@ do_install() {
#}
FILES_${PN} += "/usr/AGL/ \
- /usr/AGL/apps/* \
- /usr/AGL/${PN}/* \
/home/root/app-data/radio/presets-*.conf \
/home/root/app-data/radio/presets.conf \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \