summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb')
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
index 4ef42ee6..b78f2f56 100644
--- a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
@@ -12,9 +12,16 @@ DEPENDS = "af-binder json-c"
inherit cmake
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
SRCREV = "d97eb6052b7652a42d502e5887bd7acf3fc6d91b"
S = "${WORKDIR}/git"
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
RDEPENDS_${PN} = "agl-service-homescreen-2017"
PROVIDES += "virtual/libhomescreen"