summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer_%.bbappend')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index a4eebfb4..4e89af06 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -15,7 +15,8 @@ do_install_append() {
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
+ install -d ${D}${systemd_user_unitdir}
+ install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
fi
}
@@ -26,6 +27,6 @@ do_install_append() {
#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
FILES_${PN} += " \
- ${systemd_system_unitdir}/mapviewer.service \
+ ${systemd_user_unitdir}/mapviewer.service \
/usr/AGL/mapviewer/ \
"