summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer_%.bbappend')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index 3049a674..a4eebfb4 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -1,6 +1,7 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
+ file://mapviewer-settings.sh \
file://mapviewer.service \
"
@@ -9,12 +10,22 @@ inherit systemd
SYSTEMD_PACKAGES = "${PN}"
do_install_append() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}/usr/AGL/${PN}/
+
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
fi
}
+## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
+##
+## This should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
+##
+#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
+
FILES_${PN} += " \
${systemd_system_unitdir}/mapviewer.service \
+ /usr/AGL/mapviewer/ \
"