summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer_%.bbappend')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend23
1 files changed, 8 insertions, 15 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index 4e89af06..a5597083 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -3,30 +3,23 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://mapviewer-settings.sh \
file://mapviewer.service \
- "
+"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
do_install_append() {
- install -d ${D}/usr/AGL/${PN}
- install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}/usr/AGL/${PN}/
+ install -d ${D}${prefix}/AGL/${PN}
+ install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}${prefix}/AGL/${PN}/
- # Install systemd unit files
+ # Install systemd unit file
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_user_unitdir}
- install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
+ install -d ${D}${systemd_system_unitdir}
+ install -m 644 ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
fi
}
-## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
-##
-## This should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
-##
-#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
+SYSTEMD_SERVICE_${PN} = "mapviewer.service"
-FILES_${PN} += " \
- ${systemd_user_unitdir}/mapviewer.service \
- /usr/AGL/mapviewer/ \
- "
+FILES_${PN} += "${prefix}/AGL/${PN}/"