summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/unicens/files/0001-Fix-cross-compilation-with-yocto.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/unicens/files/0001-Fix-cross-compilation-with-yocto.patch')
-rw-r--r--recipes-demo-hmi/unicens/files/0001-Fix-cross-compilation-with-yocto.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-demo-hmi/unicens/files/0001-Fix-cross-compilation-with-yocto.patch b/recipes-demo-hmi/unicens/files/0001-Fix-cross-compilation-with-yocto.patch
new file mode 100644
index 00000000..23b6a04f
--- /dev/null
+++ b/recipes-demo-hmi/unicens/files/0001-Fix-cross-compilation-with-yocto.patch
@@ -0,0 +1,49 @@
+From e75a2aafc7fc6b845e84a1a66d4883dddbbc93e2 Mon Sep 17 00:00:00 2001
+From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+Date: Fri, 9 Dec 2016 21:53:22 +0100
+Subject: [PATCH] Fix cross-compilation with yocto
+
+Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+---
+ buildX86/Makefile-Release.mk | 18 +++++++++---------
+ 1 file changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/buildX86/Makefile-Release.mk b/buildX86/Makefile-Release.mk
+index 7419a76..72d7df8 100644
+--- a/buildX86/Makefile-Release.mk
++++ b/buildX86/Makefile-Release.mk
+@@ -11,14 +11,14 @@
+ MKDIR=mkdir
+ CP=cp
+ GREP=grep
+-NM=nm
+-CCADMIN=CCadmin
+-RANLIB=ranlib
+-CC=${CROSS_COMPILE}gcc
+-CCC=${CROSS_COMPILE}g++
+-CXX=${CROSS_COMPILE}g++
+-FC=${CROSS_COMPILE}gfortran
+-AS=${CROSS_COMPILE}as
++#NM=nm
++#CCADMIN=CCadmin
++#RANLIB=ranlib
++#CC=${CROSS_COMPILE}gcc
++#CCC=${CROSS_COMPILE}g++
++#CXX=${CROSS_COMPILE}g++
++#FC=${CROSS_COMPILE}gfortran
++#AS=${CROSS_COMPILE}as
+
+ # Macros
+ CND_PLATFORM=GNU-Linux-x86
+@@ -86,7 +86,7 @@ OBJECTFILES= \
+
+
+ # Include Path
+-C_INCLUDE=-Imnsl -ISrc -ISrc/IP -ISrc/Network -ISrc/Network/base -I/usr/include/libxml2 ${INCLUDE_PATH}
++C_INCLUDE=-Imnsl -ISrc -ISrc/IP -ISrc/Network -ISrc/Network/base -I=/usr/include/libxml2 ${INCLUDE_PATH}
+
+ # C Compiler Flags
+ CFLAGS=-c -Wall -O2 -MMD -MP -DNDEBUG ${PROJECT_C_FLAGS}
+--
+2.10.2
+