summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/vod-server/vod-server_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/vod-server/vod-server_0.1.bb')
-rw-r--r--recipes-demo-hmi/vod-server/vod-server_0.1.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
index 73b7fb74..5c3ad6a6 100644
--- a/recipes-demo-hmi/vod-server/vod-server_0.1.bb
+++ b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -24,12 +24,13 @@ do_install() {
# Execute install manually for root user on behalf of systemctl script
# because it doesn't support user mode of systemd.
- install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
- ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ sed -i "s:/home/root:${ROOT_HOME}:" ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
fi
}
FILES_${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
"