summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/vod-server
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/vod-server')
-rw-r--r--recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch25
-rw-r--r--recipes-demo-hmi/vod-server/vod-server_0.1.bb20
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch b/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch
new file mode 100644
index 00000000..c034d4ee
--- /dev/null
+++ b/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch
@@ -0,0 +1,25 @@
+--- a/buildX86/Makefile-Release.mk 2016-12-09 15:48:37.000000000 +0100
++++ b/buildX86/Makefile-Release.mk 2016-12-09 16:56:35.071740652 +0100
+@@ -11,14 +11,14 @@
+ MKDIR=mkdir
+ CP=cp
+ GREP=grep
+-NM=nm
+-CCADMIN=CCadmin
+-RANLIB=ranlib
+-CC=${CROSS_COMPILE}gcc
+-CCC=${CROSS_COMPILE}g++
+-CXX=${CROSS_COMPILE}g++
+-FC=${CROSS_COMPILE}gfortran
+-AS=${CROSS_COMPILE}as
++#NM=nm
++#CCADMIN=CCadmin
++#RANLIB=ranlib
++#CC=${CROSS_COMPILE}gcc
++#CCC=${CROSS_COMPILE}g++
++#CXX=${CROSS_COMPILE}g++
++#FC=${CROSS_COMPILE}gfortran
++#AS=${CROSS_COMPILE}as
+
+ # Macros
+ CND_PLATFORM=GNU-Linux-x86
diff --git a/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
new file mode 100644
index 00000000..949509d6
--- /dev/null
+++ b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Build VideoOnDemand server"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+# "
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
+
+S = "${WORKDIR}/git"
+#SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
+SRCREV = "${AUTOREV}"
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+}
+