summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb')
-rw-r--r--recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb b/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
index 63a315fd6..0058f26fe 100644
--- a/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
+++ b/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
@@ -31,6 +31,10 @@ USERADD_PARAM:${PN} = "--system -g 903 -u 903 -o -d / --shell /bin/nologin persi
do_compile:prepend() {
export ROCKSDB_CXX_STD="--std=c99"
export ROCKSDB_INCLUDE_DIR="${RECIPE_SYSROOT}/usr/include"
+
+ # Need to set options for the rust-librocksdb-sys crate's bindgen invocation of clang,
+ # or there's a good chance it will choke when trying to use the host system's headers.
+ export BINDGEN_EXTRA_CLANG_ARGS="${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
}
do_install:append () {