summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/cluster-dashboard/cluster-dashboard_git.bb')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb24
1 files changed, 13 insertions, 11 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index 7aba600d..7c7d4051 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -7,23 +7,25 @@ LICENSE = "Apache-2.0 & BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
file://app/cluster-gauges.qml;beginline=9;endline=48;md5=54187d50b29429abee6095fe8b7c1a78"
+DEPENDS = " \
+ qtquickcontrols2 qtwebsockets libqtappfw glib-2.0 \
+ wayland-native wayland qtwayland qtwayland-native \
+"
+
+PV = "1.0+git${SRCPV}"
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtwebsockets libqtappfw glib-2.0 \
- wayland-native wayland qtwayland qtwayland-native"
-
inherit pkgconfig cmake_qt5 aglwgt
RDEPENDS_${PN} += " \
- qtquickcontrols \
- qtquickcontrols-qmlplugins \
- qtquickcontrols2 \
- qtquickcontrols2-qmlplugins \
- libqtappfw \
- agl-service-signal-composer \
+ qtquickcontrols \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2 \
+ qtquickcontrols2-qmlplugins \
+ libqtappfw \
+ agl-service-signal-composer \
"