summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb')
-rw-r--r--recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb22
1 files changed, 12 insertions, 10 deletions
diff --git a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
index 9c975961..a0fde07e 100644
--- a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
@@ -7,22 +7,24 @@ LICENSE = "Apache-2.0 & MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
+DEPENDS = " \
+ wayland wayland-native \
+ qtwayland qtwayland-native \
+ qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
-# build-time dependencies
-DEPENDS += "wayland wayland-native \
- qtwayland qtwayland-native \
- qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
- gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
-
inherit cmake_qt5 pkgconfig aglwgt
RDEPENDS_${PN} += " \
- gstreamer1.0-plugins-base \
- gstreamer1.0-plugins-good \
- gstreamer1.0-plugins-bad \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
"