summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-cluster-dashboard
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/flutter-cluster-dashboard')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json17
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json18
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json (renamed from recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json)4
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb8
4 files changed, 4 insertions, 43 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
deleted file mode 100644
index 3d92b45f..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
+++ /dev/null
@@ -1,17 +0,0 @@
-{
- "view": [
- {
- "window_type": "BG",
- "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
- "vm_args": [
- "--observatory-host",
- "0.0.0.0",
- "--observatory-port",
- "1234"
- ],
- "width": 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
deleted file mode 100644
index aca303fb..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
+++ /dev/null
@@ -1,18 +0,0 @@
-{
- "view": [
- {
- "window_type": "BG",
- "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
- "vm_args": [
- "--observatory-host",
- "0.0.0.0",
- "--observatory-port",
- "1234",
- "--start-paused"
- ],
- "width": 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
index eb75dc4f..4bd7429a 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
@@ -2,10 +2,10 @@
"view": [
{
"window_type": "BG",
- "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard/3.3.7/release",
"width": 1920,
"height": 1080,
"fullscreen": true
}
]
-} \ No newline at end of file
+}
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index a1dc29f6..2effcfed 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -10,9 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
file://flutter-cluster-dashboard.service \
- file://flutter_cluster_dashboard_on_bg-debug.json \
- file://flutter_cluster_dashboard_on_bg-profile.json \
- file://flutter_cluster_dashboard_on_bg-release.json \
+ file://flutter_cluster_dashboard_on_bg.json \
file://flutter-cluster-dashboard.yaml \
file://flutter-cluster-dashboard.yaml.demo \
"
@@ -32,9 +30,7 @@ inherit flutter-app update-alternatives
CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
-APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service