summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-cluster-dashboard
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/flutter-cluster-dashboard')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service2
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json10
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml5
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb13
4 files changed, 15 insertions, 15 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
index 21082e7eb..83fe23508 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
@@ -7,7 +7,7 @@ User=agl-driver
EnvironmentFile=/etc/default/flutter
EnvironmentFile=-/etc/default/flutter-cluster-dashboard
Environment=XDG_RUNTIME_DIR=/run/user/1001/
-ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/flutter_cluster_dashboard/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --j=/usr/share/flutter/flutter-cluster-dashboard.json
+ExecStart=/usr/bin/flutter-auto -b /usr/share/flutter/flutter_cluster_dashboard/${FLUTTER_VERSION}/${FLUTTER_RUNTIME}
Restart=on-failure
[Install]
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
deleted file mode 100644
index c90e5e3ae..000000000
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view": [
- {
- "window_type": "BG",
- "width": 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml
new file mode 100644
index 000000000..cb78ab0cd
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml
@@ -0,0 +1,5 @@
+[view]
+window_type = "BG"
+width = 1080
+height = 1920
+fullscreen = true
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 013f4f87c..b510a88bf 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
file://flutter-cluster-dashboard.service \
- file://flutter_cluster_dashboard_on_bg.json \
+ file://flutter_cluster_dashboard_on_bg.toml \
file://cluster-dashboard.yaml \
file://cluster-dashboard.yaml.demo \
file://cluster-dashboard.yaml.gateway-demo \
@@ -21,7 +21,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-clust
"
PV = "1.0+git${SRCPV}"
-SRCREV = "e39bf6a1e3657542a56f21b3afa6a65ea0a194e2"
+SRCREV = "03dd111dd026cefaf5cfada39e3342d31b71848d"
S = "${WORKDIR}/git"
@@ -29,7 +29,7 @@ PUBSPEC_APPNAME = "flutter_cluster_dashboard"
inherit flutter-app update-alternatives systemd
-APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg.toml"
SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
@@ -40,7 +40,12 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+ # determine build type based on what flutter-engine installed.
+ for runtime_mode in ${FLUTTER_RUNTIME_MODES}
+ do
+ install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
+ ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
+ done
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default