summaryrefslogtreecommitdiffstats
path: root/recipes-demo/homescreen/homescreen_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/homescreen/homescreen_git.bb')
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb33
1 files changed, 17 insertions, 16 deletions
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index 92c24583..2940378a 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -5,33 +5,34 @@ LICENSE = "Apache-2.0"
SECTION = "apps"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS = "\
- qtbase \
- qtdeclarative \
- qtquickcontrols2 \
- agl-service-homescreen \
- agl-service-weather \
- libqtappfw \
- libhomescreen \
- libafb-helpers-qt \
- wayland-native \
- wayland \
- qtwayland \
- qtwayland-native \
+DEPENDS = " \
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ agl-service-homescreen \
+ agl-service-weather \
+ libqtappfw \
+ libhomescreen \
+ libafb-helpers-qt \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
"
-inherit qmake5 systemd pkgconfig aglwgt
+PV = "1.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git/"
+inherit qmake5 systemd pkgconfig aglwgt
+
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
RDEPENDS_${PN} += " \
- libqtappfw \
+ libqtappfw \
"