summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-dashboard
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/html5-dashboard')
-rw-r--r--recipes-demo/html5-dashboard/files/webapps-dashboard.desktop11
-rw-r--r--recipes-demo/html5-dashboard/html5-dashboard_git.bb17
2 files changed, 7 insertions, 21 deletions
diff --git a/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop b/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop
deleted file mode 100644
index 49da9649..00000000
--- a/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Dashboard
-Comment=Dashboard
-GenericName=Dashboard
-Exec=/usr/bin/WebAppMgr --appid=webapps-dashboard --app-install-dir=/usr/lib/wam_apps/html5-dashboard/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-dashboard/html5-dashboard_git.bb b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
index b5118072..8509746f 100644
--- a/recipes-demo/html5-dashboard/html5-dashboard_git.bb
+++ b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=master \
- file://webapps-dashboard.desktop \
"
SRCREV = "4680db99615757df9d9cc561c9a9fc5b9b1c108a"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-dashboard"
+AGL_APP_NAME = "HTML5 Dashboard"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-dashboard.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"