summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-homescreen/html5-homescreen_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/html5-homescreen/html5-homescreen_git.bb')
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 463aa56d..c03aee49 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -4,42 +4,42 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
SRC_URI = " \
- git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
- file://homescreen.service \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
+ file://homescreen.service \
"
SRCREV = "e85c42ae77592afdb72df8e8d4f27e0e7ad17bb9"
-inherit pythonnative
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+inherit pythonnative systemd
DEPENDS = "nodejs-native"
do_compile[network] = "1"
do_compile() {
- cd ${S}
- rm -rf package node_modules package-lock.json
- npm install
- npm run build
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+SYSTEMD_SERVICE:${PN} = "homescreen.service"
+
do_install() {
- install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
- cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
- ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -D -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
}
FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${systemd_user_unitdir} \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${systemd_system_unitdir} \
"
-RCONFLICTS:${PN} = "homescreen"
+RCONFLICTS:${PN} = "homescreen flutter-homescreen"
RDEPENDS:${PN} = "applaunchd html5-background"