summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-launcher/html5-launcher_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/html5-launcher/html5-launcher_git.bb')
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb17
1 files changed, 7 insertions, 10 deletions
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 83e7f807..3595423b 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
- file://launcher.desktop \
"
SRCREV = "1283e3bddd4655be0d5208fbbcd9535f8f1ff0f6"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "launcher"
+AGL_APP_NAME = "HTML5 Launcher"
DEPENDS = "nodejs-native"
@@ -26,20 +29,14 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
RCONFLICTS:${PN} = "launcher"
RDEPENDS:${PN} = "applaunchd"