summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-launcher
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/html5-launcher')
-rw-r--r--recipes-demo/html5-launcher/files/launcher.service15
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb11
2 files changed, 6 insertions, 20 deletions
diff --git a/recipes-demo/html5-launcher/files/launcher.service b/recipes-demo/html5-launcher/files/launcher.service
deleted file mode 100644
index 67dcf5e1..00000000
--- a/recipes-demo/html5-launcher/files/launcher.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=AGL Launcher
-Requires=WebAppMgr.service dbus.service
-After=WebAppMgr.service dbus.service
-
-[Service]
-Type=simple
-Environment=AFM_ID=launcher
-Environment=AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-launcher/
-ExecStartPre=sleep 1
-ExecStart=/usr/bin/WebAppMgr
-Restart=on-failure
-
-[Install]
-WantedBy=agl-session.target
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 2a4f7ed1..61899e4c 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -10,7 +10,7 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
- file://launcher.service \
+ file://launcher.desktop \
"
SRCREV = "${AGL_APP_REVISION}"
@@ -23,18 +23,19 @@ do_compile() {
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
- ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
}
FILES_${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
- ${systemd_user_unitdir} \
+ ${APPLICATIONS_DIR} \
"
RCONFLICTS_${PN} = "launcher"
+RDEPENDS_${PN} = "applaunchd" \ No newline at end of file