aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo/hvac/hvac_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/hvac/hvac_git.bb')
-rw-r--r--recipes-demo/hvac/hvac_git.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
index c518708c..8b4b090d 100644
--- a/recipes-demo/hvac/hvac_git.bb
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -16,13 +16,29 @@ DEPENDS = " \
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "c173b5b5fbdb9013304ad62e0dc8f8bb9a072e7d"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://hvac.conf \
+ file://hvac.token \
+"
+SRCREV = "d37674bb6dbb5ceb15c650a0344b0caf624963bc"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/hvac
+ install -m 0644 ${WORKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \