summaryrefslogtreecommitdiffstats
path: root/recipes-demo/mediaplayer/mediaplayer_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/mediaplayer/mediaplayer_git.bb')
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 7962f76c..b4fa58c8 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -10,13 +10,29 @@ DEPENDS = "qtquickcontrols2 libqtappfw"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH} \
+ file://mediaplayer.conf \
+ file://mediaplayer.token \
+"
SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
inherit qmake5
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/mediaplayer
+ install -m 0644 ${WORKDIR}/mediaplayer.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += "libqtappfw mpd"