summaryrefslogtreecommitdiffstats
path: root/recipes-demo/mediaplayer
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/mediaplayer')
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 897099af..9458212a 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -33,6 +33,12 @@ do_install:append() {
install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
}
+# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
+do_install:append() {
+ sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/mediaplayer.desktop
+ echo "DBusActivatable=true" >> ${D}${datadir}/applications/mediaplayer.desktop
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += "libqtappfw mpd"