summaryrefslogtreecommitdiffstats
path: root/recipes-demo/mediaplayer
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/mediaplayer')
-rw-r--r--recipes-demo/mediaplayer/mediaplayer/0001-Migrate-to-Qt-6.patch87
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb7
2 files changed, 91 insertions, 3 deletions
diff --git a/recipes-demo/mediaplayer/mediaplayer/0001-Migrate-to-Qt-6.patch b/recipes-demo/mediaplayer/mediaplayer/0001-Migrate-to-Qt-6.patch
new file mode 100644
index 000000000..fc7dcb234
--- /dev/null
+++ b/recipes-demo/mediaplayer/mediaplayer/0001-Migrate-to-Qt-6.patch
@@ -0,0 +1,87 @@
+From b98a116f91e967eca96ecd3052eeeb78d8002e0c Mon Sep 17 00:00:00 2001
+From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
+Date: Wed, 24 Jul 2024 09:24:39 +0900
+Subject: [PATCH] Migrate to Qt 6
+
+---
+ app/MediaPlayer.qml | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/app/MediaPlayer.qml b/app/MediaPlayer.qml
+index fd4db58..6f381da 100644
+--- a/app/MediaPlayer.qml
++++ b/app/MediaPlayer.qml
+@@ -174,14 +174,14 @@ ApplicationWindow {
+ //ToggleButton {
+ // id: random
+ // visible: bluetooth.connected == false
+- // offImage: './images/AGL_MediaPlayer_Shuffle_Inactive.svg'
+- // onImage: './images/AGL_MediaPlayer_Shuffle_Active.svg'
++ // offImage: 'qrc:/images/AGL_MediaPlayer_Shuffle_Inactive.svg'
++ // onImage: 'qrc:/images/AGL_MediaPlayer_Shuffle_Active.svg'
+ //}
+ ToggleButton {
+ id: loop
+ visible: player.av_connected === false
+- offImage: './images/AGL_MediaPlayer_Loop_Inactive.svg'
+- onImage: './images/AGL_MediaPlayer_Loop_Active.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_Loop_Inactive.svg'
++ onImage: 'qrc:/images/AGL_MediaPlayer_Loop_Active.svg'
+ onClicked: { mediaplayer.loop(checked ? "playlist" : "off") }
+ }
+ }
+@@ -228,15 +228,15 @@ ApplicationWindow {
+ RowLayout {
+ Layout.fillHeight: true
+ // Image {
+-// source: './images/AGL_MediaPlayer_Playlist_Inactive.svg'
++// source: 'qrc:/images/AGL_MediaPlayer_Playlist_Inactive.svg'
+ // }
+ // Image {
+-// source: './images/AGL_MediaPlayer_CD_Inactive.svg'
++// source: 'qrc:/images/AGL_MediaPlayer_CD_Inactive.svg'
+ // }
+ Item { Layout.fillWidth: true }
+ ImageButton {
+ id: previous
+- offImage: './images/AGL_MediaPlayer_BackArrow.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_BackArrow.svg'
+ onClicked: {
+ mediaplayer.previous()
+ }
+@@ -248,7 +248,7 @@ ApplicationWindow {
+ when: player.status == "playing"
+ PropertyChanges {
+ target: play
+- offImage: './images/AGL_MediaPlayer_Player_Pause.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_Player_Pause.svg'
+ onClicked: {
+ mediaplayer.pause()
+ }
+@@ -258,7 +258,7 @@ ApplicationWindow {
+ when: player.status != "playing"
+ PropertyChanges {
+ target: play
+- offImage: './images/AGL_MediaPlayer_Player_Play.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_Player_Play.svg'
+ onClicked: mediaplayer.play()
+ }
+ }
+@@ -266,7 +266,7 @@ ApplicationWindow {
+ }
+ ImageButton {
+ id: forward
+- offImage: './images/AGL_MediaPlayer_ForwardArrow.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_ForwardArrow.svg'
+ onClicked: {
+ mediaplayer.next()
+ }
+@@ -284,7 +284,7 @@ ApplicationWindow {
+ mediaplayer.disconnect()
+ }
+ contentItem: Image {
+- source: player.av_connected ? './images/AGL_MediaPlayer_Bluetooth_Active.svg' : './images/AGL_MediaPlayer_Bluetooth_Inactive.svg'
++ source: player.av_connected ? 'qrc:/images/AGL_MediaPlayer_Bluetooth_Active.svg' : 'qrc:/images/AGL_MediaPlayer_Bluetooth_Inactive.svg'
+ }
+ }
+ }
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 976dcc8dc..1f3b070ce 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -6,19 +6,20 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS = "qtquickcontrols2 libqtappfw"
+DEPENDS = "qtdeclarative libqtappfw"
PV = "2.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH} \
file://mediaplayer.conf \
file://mediaplayer.token \
-"
+ file://0001-Migrate-to-Qt-6.patch \
+ "
SRCREV = "0aefba20fe07dbb79d7b3683ab38c0b0b313a655"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig agl-app
+inherit qt6-qmake pkgconfig agl-app
AGL_APP_NAME = "Mediaplayer"