summaryrefslogtreecommitdiffstats
path: root/recipes-demo/mediaplayer
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/mediaplayer')
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 9458212a..ff84ae8a 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -18,7 +18,9 @@ SRCREV = "9c7c1d105faeb57a5b79578318c5731d252c5414"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "Mediaplayer"
do_install:append() {
# Currently using default global client and CA certificates
@@ -33,12 +35,4 @@ do_install:append() {
install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/mediaplayer.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/mediaplayer.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
-
RDEPENDS:${PN} += "libqtappfw mpd"